0

I have a weird problem with redis, about once every 30 minutes it disconnects every client. Log out put below. I have neither set maxclients nor does the timeout apply in this case.

Any ideas?

[23829] 29 Dec 16:32:09 * DB saved on disk
[1332] 29 Dec 16:32:09 * Background saving terminated with success
 ..................... last save ...................
[1332] 29 Dec 16:32:11 - DB 0: 71487 keys (0 volatile) in 131072 slots HT.
[1332] 29 Dec 16:32:11 - DB 10: 1270390 keys (23754 volatile) in 2097152 slots HT.
[1332] 29 Dec 16:32:11 - 240 clients connected (0 slaves), 505148952 bytes in use
.............. everything runs smoothly .............................
[1332] 29 Dec 16:32:42 - DB 0: 71487 keys (0 volatile) in 131072 slots HT.
[1332] 29 Dec 16:32:42 - DB 10: 1270407 keys (23756 volatile) in 2097152 slots HT.
[1332] 29 Dec 16:32:42 - 240 clients connected (0 slaves), 505151288 bytes in use
[1332] 29 Dec 16:32:47 - DB 0: 71486 keys (0 volatile) in 131072 slots HT.
[1332] 29 Dec 16:32:56 - DB 10: 1270389 keys (23737 volatile) in 2097152 slots HT.
[1332] 29 Dec 16:32:56 - 240 clients connected (0 slaves), 505145592 bytes in use
[1332] 29 Dec 16:32:56 - Client closed connection
[1332] 29 Dec 16:32:56 - Client closed connection
[1332] 29 Dec 16:32:56 - Client closed connection

 .......... all 240 clients disconnect here at once ............


[1332] 29 Dec 16:32:56 - Client closed connection
[1332] 29 Dec 16:32:56 - Accepted xxx.xxx.xxx.xxx:54879

.......... clients start reconnecting

[1332] 29 Dec 16:32:56 - Client closed connection
[1332] 29 Dec 16:32:56 - Accepted xxx.xxx.xxx.xxx:53152
[1332] 29 Dec 16:32:56 - Accepted 127.0.0.1:33971
[1332] 29 Dec 16:33:06 - DB 0: 71489 keys (0 volatile) in 131072 slots HT.
[1332] 29 Dec 16:33:06 - DB 10: 1270315 keys (23658 volatile) in 2097152 slots HT.
[1332] 29 Dec 16:33:06 - 225 clients connected (0 slaves), 504819848 bytes in use
[1332] 29 Dec 16:33:06 - Accepted xxx.xxx.xxx.xxx:53764
[1332] 29 Dec 16:33:06 - Accepted xxx.xxx.xxx.xxx:53766
[1332] 29 Dec 16:33:06 - Accepted xxx.xxx.xxx.xxx:54940
[1332] 29 Dec 16:33:07 - Accepted xxx.xxx.xxx.xxx:54941
[1332] 29 Dec 16:33:09 - Accepted xxx.xxx.xxx.xxx:54942
[1332] 29 Dec 16:33:09 - Accepted xxx.xxx.xxx.xxx:49227
[1332] 29 Dec 16:33:10 * 10000 changes in 60 seconds. Saving...
[1332] 29 Dec 16:33:10 * Background saving started by pid 24057
[1332] 29 Dec 16:33:11 - DB 0: 71489 keys (0 volatile) in 131072 slots HT.
[1332] 29 Dec 16:33:11 - DB 10: 1270270 keys (23615 volatile) in 2097152 slots HT.
[1332] 29 Dec 16:33:11 - 234 clients connected (0 slaves), 504908696 bytes in use

.....   everything returns to normal, for about 30 minutes .............
1

Alright, the answer was a cronjob ... but not on the Redis host. I had a different host copy a DB backup ~900MB every 30 minutes to the host which runs redis.

Apparently this caused some kind of problems, I switched the backup to a different host and since then everything runs smoothly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.