In brief: I cannot Remote desktop a particular server - say "X" from "A" server, but with MSTSC /ADMIN switch I was able to RD "X" server. But the same "X" server can be RD'd from "B" server even without ADMIN Switch.

All servers are 2012 R2 DataCenter

I am getting this weird error - An internal error has occurred, while trying to MSTSC. I was trying to remote desktop to a server from one of our servers that has connectivity allowed. All required Ports are allowed and I was able to Remote desktop to that particular server using /admin switch but not with mstsc alone. I was able to RD to other servers fine, but not to this particular server. When I try to RD it, I am getting MSTSC crash in event viewer, I get credential page and then after entering credentials I see certificate warning and then post accepting that, it says establishing connection and after few seconds it says - An internal Error has occurred. :(

I see event viewer and found Event ID 1000 -

Below is the error log:

Faulting application name: mstsc.exe, version: 6.3.9600.16384, time stamp: 0x5215e2b5 Faulting module name: ntdll.dll, version: 6.3.9600.17278, time stamp: 0x53eebd22 Exception code: 0xc0000005 Fault offset: 0x00000000000326a0 Faulting process id: 0x1d78 Faulting application start time: 0x01d0236d841ae5c5 Faulting application path: C:\Windows\system32\mstsc.exe Faulting module path: C:\Windows\SYSTEM32\ntdll.dll Report Id: ce466ba8-8f61-11e4-80f4-002dd8150a44 Faulting package full name: Faulting package-relative application ID:

I am really worried, because I was able to RD this particular failing server from a different machine, but not from this particular server.

Any idea? Please help in this case. Let me know if further information is required.

  • Reboot server A and try again.
    – joeqwerty
    Dec 29, 2014 at 17:04
  • Hello @joeqwerty - I tried that, but still no luck :(
    – chaladi
    Dec 29, 2014 at 17:06
  • @chaladi Try copying the mstsc.exe and mstscax.dll files from another computer (maybe even with a different version), and see what happens.
    – EliadTech
    Dec 30, 2014 at 18:05
  • Same issues here, any update on a solution. New Server 2012 R2 install. No RDP even from Win 7, all the same cert notifications and signoffs then the error.
    – htm11h
    Mar 25, 2015 at 18:26
  • 2
    @htm11h Follow below steps... Verify the MTU size between source to destination using "ping -f -l 1500" If it says: C:\Users\sreekanth>ping -f -l 1500 Pinging with 1500 bytes of data: Packet needs to be fragmented but DF set then lower the MTU value and test again until you see ping success. Change your Source server default MTU size to that value and that will fix. Example From CMD: Type netsh interface ipv4 show subinterface Type netsh interface ipv4 set subinterface “Local Area Connection” mtu=1400 store=persistent
    – chaladi
    Mar 26, 2015 at 2:12

1 Answer 1


With one of our terminal servers, we rebooted it each time this happened. Today, reboot did nothing so we unjoined & re-joined to the domain to fix the issue.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .