2

I'm automating a report that will essentially duplicate the information shown in the Storage Capacity Summary chart from the EMC Unisphere web interface. I need to perform this from the command line and process the results.

Items in the Unisphere chart, which is reporting on our NAS, are:

  • Used
  • Free Raw Disk
  • Free Storage Pool
  • Free Space for File

This eventually gets rolled up (right now, by "hand". Someone eyeballs the chart and compiles this stuff into an Excel file) into a report that wants to know two ("three") things:

  • Total TB
  • Allocated TB
  • Free TB

I've gotten similar looking information from running nas_storage -info <storage-id> under Disk Groups, but it's not quite as clean, and I'm not sure it's what I'm looking for.

Snippet:

Disk Groups

id                    = 0000
storage profiles      = 2 - clarsas_archive,cmsas_archive
raid_type             = RAID5
logical_capacity      = 5613414400
num_spindles          = 6 - 1_2_10 1_2_14 2_1_10 2_1_14 2_2_10 2_2_14 
num_luns              = 2 - 00240 00242 
num_disk_volumes      = 0
spindle_type          = SAS
bus                   = mixed
virtually_provisioned = False 
raw_capacity          = 6736097280
used_capacity         = 4198400
free_capacity         = 5609216000
hidden                = True

The VNX is hosted on Linux. My n00bness here is largely because the rest of report is about the VMs in VMware that use this VNX, and that part is all done in PowerCLI on Windows, where I normally live. I'm probably going to plink over from PowerShell and run a few commands on the VNX box to process and integrate our storage info. Only the NAS is Linux-based (other than some VM guest OSes).

Is nas_storage even the right/best command to run? server_stats initially looked more promising, but I get errors about unknown hosts when I tried to connect to the same server that's giving me tons of dumped info from nas_storage.

The best resource I've found is the VNX™ Command Line Interface Reference for File (login required). There's not a lot that I've been able to Google that's related to specifically what I'm doing, I don't believe (fails include: 1, 2, 3).

EDIT: The numbers I'm getting in the second Disk Groups section of the output of nas_storage -info <storage-id> is essentially exactly 2^20 bigger than the size reported in the Unisphere web client report for Storage Pools ( >>> Storage >>> Storage Configuration >>> Storage Pools), sans units. That is, the Unisphere report gives Gigabytes, and nas_storage call is giving Gigs times 2^20.

EDIT 2: The 2^20 number is because the block size, which is apparently a kiB on our system (confirmed with a naviseccli getrg call that had blocks and GB). Still not sure how to match a Unisphere report, however. Did find someone asking the question on EMC's forums in 2012 and a similar one on Clarion here but neither have an answer (or answer that you can't get these numbers, strangely).

  • Downvoter want to explain what needs improving? – ruffin Dec 31 '14 at 4:09
0

Use following command for block storage (id=0 means storage pool #)

/opt/Navisphere/bin/naviseccli -h 1.1.1.1 -User user -Password password -Scope 0 storagepool -list -id 0 -availableCap -consumedCap -UserCap -prcntFull|grep -v Blocks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.