1

Software -

  • Windows 2003 R2 - IIS 7.5 using FTP

  • FileZilla (Protocol=FTP; Encryption=Require explicit FTP over TLS; Logon Type:=Normal; UserName=****; Passwword=****** Currently there are 3 virtual drives and when I connect via FileZilla they all display fine, however when I try to configure a 4th virtual directory it will not display in FileZilla.

I am actually getting a sporadic failure all together after the directory is created:

Command: LIST Error: GnuTLS error -110: The TLS connection was non-properly terminated. Status: Server did not properly shut down TLS connection Error: Transfer connection interrupted: ECONNABORTED - Connection aborted Response: 550 Keyset does not exist Error: Failed to retrieve directory listing

If I delete the Virtual Directory the directories will display again. What is wrong, all the permissions are identical. Is there something with the SSL that has to be configured on the directory? Any assistance would be great.

  • Just to clarify, this is on Server 2008 R2, not 2003? Do you have any problems when not using TLS? – Peter Hahndorf Jan 2 '15 at 22:47
  • Yes this is on Server 2008 R2. On Monday, I will be removing SSL 2.0, 3.0 and installing TLS 1.1 and 1.2 and maybe that is the issue. This is being done because of the POODLE Vulnerability - en.wikipedia.org/wiki/POODLE. I will come back and update once I have done that. I am connecting using TLS.... – Moojjoo Jan 16 '15 at 20:18
  • Here is my solution to this problem. After HOURS and I mean HOURS of searching the Web I did the following and it resolved the problem. Window Explorer > %ALLUSERSPROFILE%\Microsoft\Crypto\RSA\MachineKeys > Right Click on Machine Key = 76944fb33636aeddb9590521c2e8815a_GUID > Granted the FTP Account -- Read & Execute; Read Access... Problem resolved. – Moojjoo Jan 16 '15 at 21:36
1

The "550 Keyset does not exist" error message may be caused by the pass-through authentication settings for the virtual directory. If pass-trough authentication is configured to use a 'specific user' rather than the default setting of 'application user' then the 550 error will be returned unless(probably) the 'specific user' is granted permission to access the Machine Keys for certificates.

  • To add to the anwser only READ permissions were granted and it fixed the error. – Moojjoo Oct 7 '15 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.