0

So I was trying to upgrade from MariaDB 5.5 to 10.0. (which is essentially MySQL fork) The installation instructions say to

yum remove mariadb-server mariadb-common mariadb-compat

then re-install the new version.... but the yum remove also removed

php-mysql
php-pear-MDB2-Driver-mysql

Now when I go to re-install php-msyql I get an error:

> yum install php-mysql
Loaded plugins: fastestmirror, replace
Setting up Install Process
Loading mirror speeds from cached hostfile
 * base: mirror.vcu.edu
 * centosplus: mirror.vcu.edu
 * epel: mirror.symnds.com
 * extras: mirror.cs.vt.edu
 * ius: mirror.symnds.com
 * rpmforge-extras: mirror.us.leaseweb.net
 * updates: mirrors.advancedhosters.com
 * webtatic: us-east.repo.webtatic.com
Resolving Dependencies
--> Running transaction check
---> Package php-mysql.i386 0:5.3.29-3.w5 will be installed
--> Processing Dependency: php-pdo = 5.3.29-3.w5 for package: php-mysql-5.3.29-3.w5.i386
--> Running transaction check
---> Package php-pdo.i386 0:5.3.29-3.w5 will be installed
--> Processing Dependency: php-common = 5.3.29-3.w5 for package: php-pdo-5.3.29-3.w5.i386
--> Running transaction check
---> Package php-common.i386 0:5.3.29-3.w5 will be installed
--> Processing Dependency: libcurl.so.3 for package: php-common-5.3.29-3.w5.i386
--> Finished Dependency Resolution
Error: Package: php-common-5.3.29-3.w5.i386 (webtatic)
           Requires: libcurl.so.3
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

Why is it even asking to install php-common??? I already have it installed:

>yum list installed|grep php
php-pear-MDB2.noarch         2.5.0-0.9.b5.el6                   @epel           
php-php-gettext.noarch       1.0.11-3.el6                       @epel           
php53u.i686                  5.3.28-4.ius.centos6               @ius            
php53u-cli.i686              5.3.28-4.ius.centos6               @ius            
php53u-common.i686           5.3.28-4.ius.centos6               @ius            
php53u-devel.i686            5.3.28-4.ius.centos6               @ius            
php53u-gd.i686               5.3.28-4.ius.centos6               @ius            
php53u-mbstring.i686         5.3.28-4.ius.centos6               @ius            
php53u-mcrypt.i686           5.3.28-4.ius.centos6               @ius            
php53u-pdo.i686              5.3.28-4.ius.centos6               @ius            
php53u-pear.noarch           1:1.9.4-3.ius.centos6              @ius            
php53u-zts.i686              5.3.28-4.ius.centos6               @ius      

And .... I already have libcurl installed!

>yum list installed|grep libcurl
libcurl.i686                 7.19.7-40.el6_6.3                  @updates        
libcurl-devel.i686           7.19.7-40.el6_6.3                  @updates        

Google says that this version of libcurl includes libcurl.so.4 and not 3. I looked in my system and there is a symlink from 3 to 4:

>ll /usr/lib/libcurl.so*
lrwxrwxrwx 1 root root     16 Jan  1 02:00 /usr/lib/libcurl.so -> libcurl.so.4.1.1
lrwxrwxrwx 1 root root     12 Feb 16  2014 /usr/lib/libcurl.so.3 -> libcurl.so.4
lrwxrwxrwx 1 root root     16 Jan  1 01:59 /usr/lib/libcurl.so.4 -> libcurl.so.4.1.1
-rwxr-xr-x 1 root root 346084 Dec  7 23:50 /usr/lib/libcurl.so.4.1.1

I noticed that libcurl.so.3 is pointing at a non-existant file, and updated it to point at 4.1.1... but still no luck.

What should I do??

It doesnt look like yum has a skip dependancy check, but I would have to use RPM -nodeps to do this. But people say bad things happen.

-1

Ok, so I solved this with rpm --nodeps ...

first downloaded all the rpms after searching for them on rpmfind.net

wget ftp://rpmfind.net/linux/centos/6.6/os/i386/Packages/php-mysql-5.3.3-38.el6.i686.rpm
wget ftp://rpmfind.net/linux/centos/6.6/updates/i386/Packages/php-common-5.3.3-40.el6_6.i686.rpm
wget ftp://rpmfind.net/linux/centos/6.6/updates/i386/Packages/php-pdo-5.3.3-40.el6_6.i686.rpm

then I ran each of them with rpm -iv just to see what happened, ofcourse they all barked about missing depedancies... so I ran them with rpm -vi --nodeps and everything works now.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.