1

I have installed nginx on my ubuntu VM. There I want Nginx to listen 443 port. My configurations are as follows.

server {
    listen 443;
    server_name wso2test.com;

    ssl on;
    ssl_certificate /etc/nginx/ssl/server.crt;
    ssl_certificate_key /etc/nginx/ssl/server.key;

    #with portOffset 0 running AS
    location /appserver/ {
        proxy_pass https://10.100.1.173:9443/;
    }

}

Then I tried and could not connect to this listening port from other machine. Then I telnet to nginx machine 443 port. It gives me connection refused output. But telnet to 80 port is connecting. what is the reason for this ?

3
  • 2
    Did you (re)start nginx after adding this config? Is this properly activated? What it is n the log files?
    – Sven
    Jan 5 '15 at 12:53
  • there was a error in my config, now working fine
    – Malintha
    Jan 5 '15 at 13:03
  • 3
    @Malintha in that case, please either edit your post to reflect the error you found and how you fixed it, or post it below as the answer (and mark it as such).
    – BE77Y
    Jan 5 '15 at 17:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.