2

I am having a hard time connecting to my office server in which I am the admin of. I have recently wiped the hard drive and re-installed os x yosemite with os x server. I use a Windows 7 machine at home which I am attempting to connect to my mac server with. I know the public IP works because I can SSH and VNC in just fine. Up until the wiping of the server I had fully working VPN services so I know they work. That and pings go through to my public IP without trouble. I keep getting as far as verifying the username / pass and it hangs and then gives an error 629 message.

I have...

  • Pinged the public server IP with 4 successful packets, every so often some have weird times like 9ms.
  • Flat out turned off my home windows firewall and also tried adding the proper exceptions.
  • Have tried using os x server automatic wizard to adjust my router port forwarding/opening of ports, as well as tried manually entering my local server ip address and port to open in airport utility.
  • Tried pinging and then connecting to the local address instead of the public address.
  • Tried turning off all forms of encryption.
  • Tried resetting the usernames / passwords.
  • Checked the accessibility feature of os x yosemite and it says VPN is available publicly.
  • Turned off automatic VPN type and manually tried both L2TP and PPTP.

UPDATE 01-07-15:

Since This Post I have now also...

  • Tried adding all OS X VPN port exceptions in airport utility under the network tab.
  • Tried to VPN into local address instead of public address.
  • Tried adding a pre-decided key or shared secret and forcing L2TP
  • Hooking up my co-workers desktop Mac machines to VPN via local/public addresses. Both worked and they also can send/receive/administer file sharing on the server.

The error 629 from my Windows client side gave a report generator which pumped out a 500 page "summary" ... I will cut out the seemingly important details:

Installation Check: Unable to validate installed Remote Access components.

Phone Book Files: Device=WAN Miniport (IKEv2) <-- Weird because I don't think this should be IKEv2

Remote Access Event Logs

Event Type: Error
Event Source: RasMan
Event Category: None
Event ID: 20276
Description: : The connection attempt failed on port: VPN3-1 because of the authentication protocol selected. Check to see if the authentication protocol is supported in the operating systems at the client and server ends of the connection

Anything else needing to be copied from that error report, lemme know.

  • Since IKEv1 is pretty much broken, it had better be IKEv2! – Michael Hampton Jan 6 '15 at 19:30
  • I meant I thought since it was Windows to Mac OS X it required L2TP or PPTP and rarely ever IKEv2 . My main reason for bringing it up is that I wonder if this means my driver for my NIC on my home comp is wrong. – GoreDefex Jan 6 '15 at 19:37
  • Well, PPTP has been broken for years, and nobody should be using it anymore (though some people are). So you shouldn't see that either. I think it's time you looked at exactly what you set up on your Mac. – Michael Hampton Jan 6 '15 at 19:44
  • I have the yosemite os x server software so I have clicked on the option that says L2TP or PPTP – GoreDefex Jan 6 '15 at 19:49
0

In case anyone is searching this question off of Google, I have solved the problem.

It was because I was using special characters in my L2TP Shared Key set inside of my Mac server. For example "jYrFF4**sX".

Once I removed the "**" from it, all connected just fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.