11

I have a hyper v server that I am connected to using remote desktop in full screen mode. Life is good.

I then connected to one of the virt machines in the and selected 'View | Full Screen Mode' which funnily enough, took me to full screen mode. That is, I have a full screen VM running inside a full screen remote desktop session.

However, pressing 'Ctrl+Alt+Break' simply maximises/restores the full screen mode of my original remote desktop session, without affecting the full screen mode.

The only sequence of events that seem to get me out of the full screen of the VM is: i) press 'Ctrl+Alt+End' which shows the Remote Desktop's equivalent of 'Ctrl+Alt+Delete' ii) Select Task Manager. This shows the Remote Desktop's Task Manager on top of the Full Screen VM, as well as showing the taskbar. iii) right click VM's icon on the taskbar and click close iv) re-connect to the VM from the Hyper-V manager

Is there an easier way?

(Yes, laugh all you want)

11 Answers 11

8

Whenever I nest RDP sessions or RDP -> VM sessions I always unstick the initial RDP sessions toolbar (clicking the tack icon will toggle it). This will cause it to slide out of view revealing the secondary connection bar of the nested RDP or VM window session. Now if you go three levels deep, you're on your own :).

  • 1
    :$ well, yes, I didn't even think to unpin the remote desktop session. Thanks everyone for holding in your mirth. – cmroanirgo Sep 16 '09 at 22:40
  • Nice! -- and don't worry @cmroanirgo, you're not the only one. XD – BrainSlugs83 Nov 4 '15 at 10:05
10

Ctrl+Alt+Pause should get you out of full-screen mode when using hyperV in full screen mode inside a remote desktop session.

  • 7
    This doesn't work. It just restores/maximizes the primary RDP (my desktop to the hyper-v server) NOT the full-screened vm in that RDP session. Joshua's answer is the correct one - to unpin the 'header' bar for the initial RDP session revealing the one underneath. – JoelAZ Feb 15 '15 at 20:36
6

None of the suggested key combinations bring me out of hyperv fullscreen mode. However, I found a two key sequence workaround. Pressing ctrl+alt+left-arrow causes the notebook to rotate display -90 degrees and releasing fullscreen mode. Quickly follow with ctrl+alt+up-arrow to restore normal mode. You are now out of fullscreen mode.

  • This works great on laptops without a full keyboard that has a pause\end button – Eric Oct 31 '16 at 0:27
2

You don't have the remote desktop tab at the top of the screen for the 2nd RDP session? I have one for the parent session, which slides up, revealing the 2nd tab, from which I can 'restore down' to a smaller window.

Best solution - this is easily justification for a larger screen, wherein you can run a non-fullscreen session comfortably. ;)

  • Thanks kara, although your answer is correct, I found Joshua's below a bit clearer. Note that I am using a 24-inch wide screen. The reason to go full screen is to get full keyboard support. – cmroanirgo Sep 16 '09 at 22:42
  • 1
    You know, I like Joshua's answer better, too. ;) – Kara Marfia Sep 17 '09 at 11:40
2

I figured this out, after reading

"You don't have the remote desktop tab at the top of the screen for the 2nd RDP session? I have one for the parent session, which slides up, revealing the 2nd tab, from which I can 'restore down' to a smaller window."

The VM in full screen tab at the top of the RDP session, you need to drag the RDP one to either side, thus revealing the VM tab underneath it. Then you minimize the VM & you're out of full screen... Silly Microsoft stuff...

2

I've found that it works with CTRL-ALT-BREAK/PAUSE using the CTRL-ALT on the RIGHT HAND side of the keyboard, but not the left hand side!

0

There is an option that does a lot of what one would want to do, even when linux is in the vm. CTRL-ALT-Left Arrow, releases the pointer from the full screen client environment. Immediately after, pressing the Windows key brings forth the taskbar and the start menu of the host.

0

Adding to gkakas' suggestion of using CTRL-ALT-Left Arrow followed by Windows key, in Windows 10 you can use the Virtual Desktop usually found to the right of the Cortana "Ask me anything" to create a new desktop for using the host. It makes it easier to switch between them and have a real host desktop without the vm coming back when you don't want it to.

  • You can't exit virtual desktop when Hyper-V in full screen mode, 'cause input is caught by VM. – Suncatcher Feb 10 '17 at 10:28
0

For those still perusing by looking for the correct answer, it's actually CTRL+ALT+LEFT ARROW to free your mouse.

0

I just had the same problem. What I did was CTRL-ALT-END which allowed me to logout off RDP killing off the VM console on the way. It was gone when I logged in.

0

You can just click the Minimize buttons on the RDP window panes when you've Inception'd your way too far into Fullscreen. You can also just drag the panes to the side to access the other pane(s) behind it.

enter image description here

protected by Sven Aug 10 '17 at 10:29

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.