2

The Background

Recently I've changed php5-fpm in favor of hhvm, that is really what they said, a "holly performance grial"

I've installed hhvm remove php5-fpm (is really a fallback needed??) following this instructions : https://bjornjohansen.no/hhvm-with-fallback-to-php.

I have multiple websites(domains) inside this VPS, and most of them are wordpress + nginx + W3TC + Ubuntu 12.0.4p + MariaDB 10ish

The Main Problem

Since the change, randomly hhvm suddenly stops running . Don't really know why , so I decide to follow the last step of the tutorial, installing ps-watcher and detecting if the service is not running and checking every 5 seconds to re-start it again.

The Configuration

hhvm.conf:

location ~ \.(hh|php)$ {
    proxy_intercept_errors on;
    #error_page 502=@fallback;

    try_files $uri =404;

    fastcgi_split_path_info ^(.+\.php)(/.+)$;

    fastcgi_keep_conn on;

    fastcgi_buffer_size 128k;
    fastcgi_buffers 256 16k;
    fastcgi_busy_buffers_size 256k;
    fastcgi_temp_file_write_size 256k;

    include         fastcgi_params;

    fastcgi_index   index.php;
    fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
    fastcgi_param   SERVER_NAME $host;
    fastcgi_pass    127.0.0.1:9000;
}

# location @fallback {

    #     try_files $uri =404;

    #     fastcgi_split_path_info ^(.+\.php)(/.+)$;

    #     include         fastcgi_params;
    #     fastcgi_index   index.php;
    #     fastcgi_param   SCRIPT_FILENAME $document_root$fastcgi_script_name;
    #     fastcgi_param   SERVER_NAME $host;
    #     fastcgi_pass    unix:/var/run/php5-fpm.sock;

# }

/etc/hhvm/server.ini

; php options

pid = /var/run/hhvm/pid

; hhvm specific

;hhvm.server.file_socket = /var/run/hhvm/hhvm.sock
hhvm.server.port = 9000
hhvm.server.type = fastcgi
hhvm.server.default_document = index.php
hhvm.log.use_log_file = true
hhvm.log.file = /var/log/hhvm/error.log
hhvm.repo.central.path = /var/run/hhvm/hhvm.hhbc

/etc/hhvm/php.ini

; php options
session.save_handler = files
session.save_path = /var/lib/php5
session.gc_maxlifetime = 1440

; hhvm specific
hhvm.log.level = Warning
hhvm.log.always_log_unhandled_exceptions = true
hhvm.log.runtime_error_reporting_level = 8191
hhvm.mysql.typed_results = false
hhvm.log.header = true
hhvm.log.natives_stack_trace = true

; Customs

max_execution_time = 300
max_input_time = 60
memory_limit = 128M
post_max_size = 12M
upload_max_filesize = 12M

tail /var/log/hhvm/error.log: Brought this Warning that W3TC Developers said that will be Fix next release (thes said this 2 releases ago :P )

[Tue Jan  6 23:27:30 2015] [hphp] [3730:7faf42fff700:1:000006] [] \nWarning: Parameter 1 to W3_Plugin_TotalCache::ob_callback() expected to be a reference, value given in /sites/public/wp-includes/functions.php on line 3269
[Tue Jan  6 23:27:40 2015] [hphp] [3810:7f99bbfff700:1:000001] [] \nWarning: Parameter 1 to W3_Plugin_TotalCache::ob_callback() expected to be a reference, value given in /sites/public/wp-includes/functions.php on line 3269

and a Bunch of several Wordpress problems releated with Template Incompatibilities.

Any adivice that could help me to detect what is happening.

thanks!

0

Well the reason of this seems to be that hhvmdoesn't accept multiple virtual hosts .

https://github.com/facebook/hhvm/issues/885

  • It "accepts", with the restriction that every virtualhost needs to be accessible with the same hhvm's user (which can be a serious security issue). – Paulo Coghi Oct 20 '15 at 15:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.