I posted this question on Super User without any responses, but I am working on a domain and want to change many computers as an administrator, so I believe it is also on topic here.


On Windows 7 and Outlook 2013, attachments saved as .xml seem to open in Internet Explorer regardless of what is set as the default program. In Control Panel, under Default Programs, my users have .xml associated with their program of choice (UAD Reader if it matters.) If there is an .xml file on the user's desktop and they double click it, it opens in the default program as expected. But when the same .xml file is an attachment in Outlook, it always opens in Internet Explorer. After reading this Microsoft article, it doesn't seem that this is an Outlook security setting as Outlook allows the file to be opened as attachment, just not in the expected program.

Is there a way to change this? I don't believe there are any built-in GPOs for this. Perhaps a registry value that would force it to open in the program I want? I'm looking for a solution that doesn't involve installing third party software and that can be handled via Group Policy or a login script.

UPDATE: If I right click and choose "Open With..." and set Notepad++ to be the default program, Outlook will then open XML files in Notepad++. If I set it back to UAD Reader, Outlook launches IE to open .xml files. I am not sure if this is an issue with UAD Reader, I'm running into an odd Windows security feature, or something else entirely.

  • In the Default Programs (Set your default program) do either Outlook or IE have an entry for .xml files? I've seen this problem with other file extensions, where the default association for the file type is something, but another program has that file type under its associations as well. – HopelessN00b Jan 7 '15 at 17:39
  • As a test, I just did the usual right click Open With..and changed it to Notepad++ and ticked it to always do so, and it appeared to have worked. On the desktop as you described, and also in Outlook (I use 2013). – Jon Weinraub Jan 7 '15 at 17:44
  • @HopelessN00b, they do not. The only association I can find is for UAD Reader. – thunderblaster Jan 7 '15 at 17:53
  • Does the behavior change if you change the default association? Set the association to anything else, and see if Outlook honors that change or not. – HopelessN00b Jan 7 '15 at 17:56
  • @JonWeinraub see my update. I'm not sure if this is an unresolvable issue with this piece of software, or if Windows just doesn't like it. I'll see if I can figure out what registry values are being changed and see if there's any differences between UAD and N++. – thunderblaster Jan 7 '15 at 18:08

After diffing my entire registry before and after the change, I found that setting Notepad++ to the default set "Progid"="Applications\\notepad++.exe" in [HKEY_USERS\S-1-5-21-73586283-1229272821-725345543-2231\Software\Microsoft\Windows\CurrentVersion\Explorer\FileExts\.xml\UserChoice]. With UAD Reader as the default, "Progid" in the same location was set to "xmlfile".

To fix this, I set "Progid"="Applications\\alamode.uadreader.exe". This completely fixed my problem and now XML files open in UAD Reader even as attachments in Outlook.

NOTE: If you are manually editing that entry in the registry, you will need to give yourself write permission to it.

I don't know why changing this in Default Programs or setting it to Always open with... doesn't set this entry, but at least it's something that can be deployed via Group Policy.

  • You should mark this as the answer :) – austinian Jan 8 '15 at 1:38
  • @austinian I can't do so for 2 days. If anyone had a good explanation of why this happens or a less messy fix. I'd gladly accept theirs before mine. – thunderblaster Jan 8 '15 at 4:13
  • Nice job in solving it. Out of curiosity, which tool did you use to diff the registry? – Jon Weinraub Jan 8 '15 at 14:33
  • DiffMerge. Thanks for your help in solving it Jon! – thunderblaster Jan 8 '15 at 16:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.