0

I'm trying to use quagga with RIP2 to route traffic through an openvpn server.

At the moment I'm having trouble because it's reporting the VPN subnet (172.19.2.x) as just a single IP (172.19.2.1). I've clearly missed a step but I'm not finding anything obvious in the documentation to point out why this is happening.

My Draytek (2820) router reports it's routing table as:

Key: C - connected, S - static, R - RIP, * - default, ~ - private
*            0.0.0.0/ 0.0.0.0          via 132.93.20.1      WAN2
C       132.93.20.0/ 255.255.254.0    directly connected    WAN2
C~      192.168.10.0/ 255.255.255.0    directly connected    LAN 
R~        172.19.2.1/ 255.255.255.255  via 192.168.10.10     LAN  (2/88050)

The zebra.conf configuration on the VPN server (192.168.10.10) is:

! -*- zebra -*-
hostname jupiter-zebra
password [removed]
enable password [removed]

! Tried adding this but didn't help
! ip route 192.168.10.0 255.255.255.0 eth0
! ip route 172.19.2.0   255.255.255.0 tun0

log file /var/log/quagga/zebra.log

The ripd.conf configuration on the VPN server is:

hostname jupiter-rip2
password [removed]

router rip
 network 192.168.10.0/24
 network 172.19.2.0/24
log file /var/log/quagga/ripd.log

Is there anything I've clearly missed to get my VPN server to report it's VPN subnet (172.19.2.x) instead of only it's VPN ip (172.19.2.1)?

  • Okay the issue here is with OpenVPN. I'll be posting an answer once I've got everything sorted. – Philip Couling Jan 14 '15 at 18:45
1

I think you should allow ospf to redistribute kernel routes:

OSPF: how to advertise the subnet of an OpenVPN server?

Example:

router ospf ospf router-id 10.0.6.1 redistribute connected redistribute kernel network 10.0.4.0/24 area 0.0.0.0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.