3

After creating fresh LXC based on Debian Jessie, on a Ubuntu 14.04, systemd-journal eats all CPU available.

lxc-create -n jessie -t debian
8

As mentioned in Debian wiki:

Add to container's config /var/lib/lxc/{container}/config:

lxc.autodev = 1
lxc.kmsg = 0

and comment out /var/lib/lxc/{container}/rootfs/lib/systemd/system/getty@.service

  ConditionPathExists=/dev/tty0

Then restart container. Same problem with Fedora host mentioned here

| improve this answer | |
  • per the above mentioned Fedora post, you also need to: Delete ${LXC_PATH}/${container}/rootfs.dev/kmsg – David H. Bennett Feb 16 '16 at 16:31
  • Now that the kmsg parameter is no longer supported in lxc, is there a way to solve this issue without it @Tombart? – Quint Jan 15 '19 at 16:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.