4

I'm installing Ubuntu onto a HP Proliant DL360 G7 server, which has a hardware Smart Array RAID controller that is not compatible with Ubuntu.

HP say the RAID controller needs to be disabled in the BIOS in order to install Ubuntu.

The problem is, with the RAID controller enabled the installation can see the hard drives to install on but then can't boot, with it disabled the installation can't see any hard drives.

UPDATE: Ubuntu installs with hardware RAID active but hangs on "Attempting to boot from hard drive C:"

I've been advised to put the server into rescue mode and reinstall GRUB but holding down shift at any time during boot doesn't bring up the GRUB menu (I've tried it many times at different points), the Ubuntu Live USB does not have a rescue mode option.

  • You say the RAID controller isn't supported in Ubuntu, so what help are you expecting us to offer here? – Andrew Schulman Jan 8 '15 at 17:11
  • I said that it can be installed but without using the hardware RAID, please read the question before posting – swdee Jan 8 '15 at 19:09
  • Perhaps windoze is installed on C drive and you installed Ubuntu on a different physical drive. If the mbr is fubar on C and bios is cfg'd to boot from that drive then that could be yee prob. – user264077 Jan 9 '15 at 3:14
  • 1
    You're doing something wrong here. Are you certain these are not used servers? DL360 G7 servers haven't been sold for 2 years. Did you check the inside of the server for any USB or SD card devices? – ewwhite Jan 9 '15 at 13:25
  • 3
    Setup a video camera and capture the following to Youtube: Start Over. Set the server back to factory defaults, clear the array, recreate the array and logical drive, install Ubuntu on that logical drive. If it still fails, ewwhite or others will be able to point out in the video where you went wrong. – TheCleaner Jan 9 '15 at 14:20
11

This is not true. The DL360 G7 server uses an HP Smart Array P410 controller. This uses the standard CCISS or HPSA drivers that have been in the Linux kernel for ages. You won't need anything special in order to install Ubuntu on this platform.

Be sure to create a Logical Drive in the BIOS RAID utility first, though. Otherwise, your Ubuntu installation won't see any disks to install to...


Edit:

It seems as though you've already installed Ubuntu. So your boot issue may be something else. Please be sure to select your boot volume in the BIOS.

grrr

Edit:

Please make sure you have the right setup in the BIOS boot order screen:

Edit:

You mentioned that you installed Ubuntu with a USB drive. That would impact the enumeration of the SCSI devices presented during the GRUB installation:

When it comes to installing the grub bootloader, make sure you specify the HD disk device (/dev/sdb) and not the USB stick (/dev/sda) otherwise it won't boot when you remove the USB stick.

  • What I said is true ubuntu.com/certification/hardware/201104-7600 – swdee Jan 8 '15 at 19:06
  • 1
    I setup the logical drive as stated but server gets stuck on "Attempting to boot from hard drive C" – swdee Jan 8 '15 at 19:07
  • Please confirm the type of controller in the system. – ewwhite Jan 8 '15 at 19:09
  • Not at work right now but I'm sure it's the P410i – swdee Jan 8 '15 at 19:19
  • Well why did the HP website say otherwise and why, after installing Ubuntu is it stuck on "Attempting to boot from hard drive C" – swdee Jan 8 '15 at 19:25
2

Check your BIOS / EFI boot settings. I would suggest switching your motherboard into BIOS boot mode and disabling EFI boot to see if you can get it to install and boot.

While the installation CD may be compatible with both EFI and BIOS, your RAID controller may not be. Ubuntu doesn't assign drive letters such as "C" and would never print anything to screen saying "Attempting to boot from hard drive C", that's either your BIOS/EFI boot or the RAID controller itself.

To my knowledge, most RAID controllers do not work in EFI mode in Linux, but will operate in Windows, explaining why HP could claim that it is incompatible/unsupported.

  • Yeah, I have no clue where the "Attempting to boot from hard drive C" would come from. – ewwhite Jan 8 '15 at 21:06
  • The sever is already is BIOS boot mode it doesn't use EFI, at square one here, don't know what do. I've never had this problem with any other server – swdee Jan 9 '15 at 10:37
1

Try here: http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/Problems-booting-up-G5-servers-after-firmware-upgrades/td-p/6210531#.VK_k9nuUJSA

Specifically:

This turned out to be a misterious Grub2 issue that was triggered by the storage array firmware upgrade. The moment we replaced Grub2 with Extlinux on affected servers, booting problems dissappeared for good. This has been verified for three servers which started having boot problems over the past three months.

Other possibilities:

http://h30499.www3.hp.com/t5/ProLiant-Servers-ML-DL-SL/ML350-G3-Attempting-to-boot-from-hard-drive-c-hanging/td-p/5112137#.VK_lEnuUJSA

http://ubuntuforums.org/showthread.php?t=1199866

  • Thanks I've seen this before but when I go into terminal from a Live USB, it doesn't see any hard disk partitions to install Extlinux or or to upgrade GRUB, just sees the USB stick same in rescue mode – swdee Jan 9 '15 at 15:39
1

If you installed Ubuntu from a USB drive, try connecting the USB drive again and reboot. If Ubuntu runs normally execute (device could change):

sudo grub-install /dev/sda

Disconnect the USB drive and restart the system.

Based on 'ewwhite' answer.

0

I tried several times to install Ubuntu 14.04 LTS and 15.04 from a bootable USB onto a DL380 G7 without CD/DVD-drive. The installation looked fine, but every attempt to boot resulted in the dreaded ""Attempting to boot from hard drive C:" followed by a hanging system.

I finally succeeded by defining the ISO as a virtual CD in the iLO and temporarily changing the boot menu to boot from CD (pressing during boot).

Hope this helps someone else.

-1

This all happened by trying to install Ubuntu 14.10, instead I tried 12.04 and it worked first time! Must have something conflicting in 14.10 with this server.

SOLVED!

Thanks to everyone for trying to help

  • Remove this answer as this actually doesn't help to solve the aforementioned problem. – Jaime Hablutzel Jun 1 '16 at 16:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.