2

I'm using a Cisco RV325, and I don't have access to any bigger/better routers.

My understanding is that the RV325 should still support the necessary security protocols to connect to the Azure site-to-site VPN, but since it's not one of the major models supported by Microsoft, MS doesn't provide a configuration guide.

Directly from the Azure portal, I downloaded the automatic VPN configuration script for one of the other Cisco routers, and tried to piece together the technical requirements.
I found SHA listed in a bunch of places (as opposed to MD5), and AES 256, and I also found Group 2
So I plugged these values into the VPN configuration wherever I could, with the faint hope that maybe I'd get lucky and it would just work - but alas I can't expect it to work when I have no idea what I'm doing. :)

Currently the VPN just says "Connecting ..." indefinitely, from both sides (from my Cisco router, and from Azure).
The connection doesn't complete or finalize.

I've posted my router's VPN configuration below. I don't know how half of the options apply to Azure's VPN configuration requirements. Is there simply a different combination of options that I could select to make the VPN work?

enter image description here

5
  • I assume you worked through the following info? msdn.microsoft.com/en-us/library/azure/jj156075.aspx – Vick Vega Jan 8 '15 at 22:23
  • @VickVega I hadn't seen this yet. I'm reading it now. – Giffyguy Jan 8 '15 at 22:24
  • @VickVega Thanks so much for providing that article. I was able to figure out what was wrong. All of the settings were correct, except according to the article I needed to disable Perfect Forward Secrecy. Once I turned off Perfect Forward Secrecy, the VPN connected and everything worked. Since you pointed me in the right direction, please post this as an answer, and I'll accept it. Thanks again! – Giffyguy Jan 8 '15 at 22:36
  • Glad it worked for you. – Vick Vega Jan 8 '15 at 22:38
  • Hello, I am having the same issue, and was hoping you could help me out too: serverfault.com/questions/821185/…. I took a few ideas from your post to be able to post mine effectively too. Thanks. – Bill Daugherty Dec 16 '16 at 17:13
5

Please have a look at the following:
https://docs.microsoft.com/en-us/azure/vpn-gateway/vpn-gateway-about-vpn-devices

According to the documentation, assuming all of your network information is correct, you should disable Perfect Forward Secrecy if you are using static routing.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.