0

first sorry for my bad English, try to explain my problem as clearly as possible.

I have a strange problem on one of my servers,

I run a plesk 12 server,

I have 2 php versions.

The default php version 5.3 in /usr/bin

This working fine, and I can install modules here, PHPIZE version is:

/usr/bin/phpize -v
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626

No problems there.

I have second PHP versión in /opt/php55

Here I cant compile any module:

/opt/php5.5/usr/bin/phpize -v
Configuring for:
PHP Api Version:         20121113
Zend Module Api No:      20121212
Zend Extension Api No:   220121212

I run

/opt/php5.5/usr/bin/phpize ./configure make make install

As always

But the module is installed in the incorrect path..

I edit all paths on phpize:

# Variable declaration
prefix='/opt/php5.5/usr'
datarootdir='/opt/php5.5/usr/share'
exec_prefix="`eval echo /opt/php5.5/usr`"
phpdir="`eval echo /opt/php5.5/usr/lib64/php`/build"
includedir="`eval echo /opt/php5.5/usr/include`/php"
builddir="`pwd`"

So I can compile modules for php5.3 but not for php 5.5, if I try to copy module to php5.5 modules dir I get error:

PHP Warning:  PHP Startup: memcache: Unable to initialize module
Module compiled with module API=20090626
PHP    compiled with module API=20121212

I try edit manually php.h zend_module.h zend_extension.h of php 5.3 but dont help always api number is API=20090626

closed as off-topic by HopelessN00b Feb 19 '15 at 10:48

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

  • Administration panels are off topic. – HopelessN00b Feb 19 '15 at 10:48
2

When you build an extension for each version of PHP, follow like as below

For 5.3

/usr/bin/phpize
./configure
make
make install

And for 5.5

/opt/php5.5/usr/bin/phpize
./configure --with-php-config=/opt/php5.5/usr/bin/php-config
make
make install

Please edit to correct path. Above just example.

  • Hi, thanks for reply, I edit some lines on php-config and now working, that file also had some paths bad defined, like: include_dir="", so thank you very very much. – Skamasle Jan 10 '15 at 20:41
  • Your welcome my friend. – tquang Jan 11 '15 at 3:24

Not the answer you're looking for? Browse other questions tagged or ask your own question.