2

I set up several ubuntu LXC containers on my ubuntu server.
They all have a unique IP configured.
As they start up, some of them do bind more than the defined IP address.
For example container A has 10.0.3.123 and binds additionally 10.0.3.127.

Thank you for any help.

LXC version: 1.0.6-0ubuntu0.1

The configuration of the container CA:
lxc.include = /usr/share/lxc/config/ubuntu.common.conf
lxc.arch = x86_64
lxc.rootfs = /var/lib/lxc/CA/rootfs
lxc.utsname = CA
lxc.console = /var/lib/lxc/CA/console
lxc.mount = /var/lib/lxc/CAfstab
lxc.network.type = veth
lxc.network.flags = up
lxc.network.link = lxcbr0
lxc.network.ipv4 = 10.0.3.123/24
lxc.start.auto = 1

The output of # lxc-ls -f:
NAME STATE IPV4 IPV6 AUTOSTART
----------------------------------------------------------------------
CA RUNNING 10.0.3.123, 10.0.3.127 - YES

  • Edit your post and paste : - /usr/share/lxc/config/ubuntu.common.conf (host) - /etc/network/interfaces (lxc container) – gilito Mar 2 '15 at 8:07
1

Your container is most likely assigning 10.0.3.127 from the built-in dhcp server. Disable dhcp inside the container or disable the assignment in the config.

  • found the crendentials for the portal, now i can say thank you :) – wolxXx May 28 '15 at 12:13
  • @wolxXx, glad I could help. Please mark this as resolved then. – Devon May 28 '15 at 23:45
  • /etc/lxc/dnsmasq.conf: dhcp-host=CA,10.0.3.10 dhcp-host=CB,10.0.3.11 dhcp-host=CB,10.0.3.12 etc – wolxXx Sep 27 '15 at 10:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.