0

I recently bought a ProLiant DL380 Gen9, i've had some trouble getting it up and running...I ran the ProLiant SPP ISO to uprade firmwares but felt the system became less stable as a result, at one point the system got stuck on the Windows loading screen, it seemed to cause the fans in the server spin up as fast as possible which as you can image was incredibly loud, after a long time i had no choice but to hard reset it, this is when the bigger problems started.

During post on the HP loading screen it said there was an error with Smart Array P440, it said something about cache being disabled and that it needed configuring, i re-configured the controller i even deleted the raid arrays and started again but now everytime i boot the system it says the same thing during post that the Array controller needs configuring.. i then get a warning in yellow saying there is errors, press F1 to continue or F2 to view them, pressing F2 takes me to 'Device Health Status' which shows:

Embedded : Smart Array P440ar Conteoller - Device configuration required, which then takes me to HP Smart Storage Administrator.

I can continue and everything works as normal... but how do i get rid of the error?

If i run diagnostic report on the controller i find only one CRITICAL error:
Box failure due to primary IO module

  • This video will help you to configure RAID/Array on HP G9 servers youtu.be/d-Xc5MVCjw0 – user333628 Jan 24 '16 at 6:42
1
  • What operating system are you using?

  • Are there any warning lights on the exterior of the server chassis.

  • Post the errors you received. The actual text, please.

  • Contact the vendor you purchased from.

  • Call HP for support.

I suspect cache module failure, but this machine has so many built-in health checks that you should not be in the dark about what's happening.

Can you boot into the Intelligent Provisioning screen (press F10 at boot) and see what the diagnostics say?

  • Windows Server 2012 R2 Data Centre, No all lights are green.. The error at post is: "Device configuration required", if I change something like the Read/Write Cache Ratio (i'm assuming this resets it) the error is different: 1797-Slot 0 Drive Array - Write-Back Cache Backup Previously Failed. Caching is disabled. Yes diagnostics only shows this error: "Box failure due to primary IO module". Thanks – Goodbytes Jan 11 '15 at 14:27
  • Your cache module failed. Please contact HP or your vendor for a replacement. – ewwhite Jan 11 '15 at 14:28
  • Thanks ewwhite.. I guess i'll call HP, is it normal for loss of power to completely kill the cache? it is brand new. – Goodbytes Jan 12 '15 at 8:44
  • It doesn't matter if it's normal or not. Sometimes things fail. HP will resolve it. – ewwhite Jan 12 '15 at 8:45
  • Thanks, after 3 hours on the support call we couldn't shift the errors, got the cache functioning properly but it was locked on to 'device needs configuring' .. there is another controller on it's way to me. – Goodbytes Jan 12 '15 at 15:28
0

As it news, I would call for the board warrenty. The cache error can be seen as its usually the battery pack, you might not have it, but the other error you facing is not normal.

0

Here's my experience with very similar equipment (tested on two separate servers), different O/S, in the hope it might be useful.

ProLiant DL360 Gen9 with HP Smart Array P440ar Controller. O/S VMWare 5.0.0 and also VMWare 5.5.0 using HP install ISO in both cases (comes bundled with drivers, etc). Controller firmware was 2.52, Hardware Revision: B. Also 2G Cache module with battery (only gives 1.8G of actual cache). Drives are Samsung EVO SSD 850 (not HP branded). Setup as RAID-5 with 5x 1T drives, after SSD over-provision you get about 3.5T in VMWare datastore.

Disabled the HP SSD Smart Path.

Set the logical drive controller cache to mostly write, tried tinkering read/write balance, you need at lest about 10% write to get decent performance out of it.

End result: good performance, but poor stability. We had incidents where drives were marked as "failed" but nothing wrong with the drive whatsoever. On a reboot it happily picks up the drive again, or do a hot-swap with identical drive and check supposedly "failed" drive on another machine... nothing wrong with it.

Another strange symptom: in some (but not all) cases the first parity initialization failed, however the RAID array still showed no errors, no warnings, appeared to work normally, HP support could not give a clear answer as to whether the "Initialization Failed" is important or not. Instability was observed BOTH in systems where we got "Initialization Completed" status and also where it got "Initialization Failed" status.

I'm 95% sure it's a controller firmware bug, cannot get HP to admit anything, they blame the Samsung drives (which are new and work fine, and we use same drives elsewhere). HP support are very unenthusiastic about helping you once they see you are using non-HP branded drives.

Newer controller firmware version 3.56 came out December 2015 so my equipment has been recently updated. So far (touch wood) no problems, early days, see if it lasts.

  • I will follow up on the topic of firmware bugs, this from HP website: Version:3.52 (30 Oct 2015) Fixes Erroneous Critical message displayed in ADU: “Box Failure Due To Primary Io Module” -- search for CP028710.zip firmware update. – Guest Jan 7 '16 at 2:02

protected by Community Jan 24 '16 at 17:27

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.