3

I have a SOLR Master and a Slave running. After upgrading to SOLR 4.10.2, and fixing all other errors, I cannot get pass this one:

RSolr::Error::Http - 500 Internal Server Error Error: {msg=SolrCore 'collection1' is not available due to init failure: Index locked for write for core collection1,trace=org.apache.solr.common.SolrException: SolrCore 'collection1' is not available due to init failure: Index locked for write for core collection1 at org.apache.solr.core.CoreContainer.getCore

I have:

  • stopped jetty on both master/slave,
  • remove the write.lock file from both machines,
  • restart slave,
  • restart master.

The issue persists.

I have also tried other solutions, like changing the following into the solrconfig.xml:

<unlockOnStartup>true</unlockOnStartup>

This caused different errors, so I rolled back to (the above part is now commented out.

I have compared the configuration files with an environment that works and they look identical.

Thank you.

0

OK, this being a new infrastructure it took me some time to adapt. As well it uses chef to deploy the packages so I had to dig into that as well. The basic idea is to make sure that (in my case jetty) is using the correct .war file. The error was caused by jetty pointing to the solr-4-10-2.war instead of the plain solr.war

So, after installing solr-4.10.2 I had to tell chef to move the .war file to the correct location and make sure that some.XML config is OK.

Anyway, problem solved. Hope that it will help someone with similar setup.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.