I have a Windows 2008 Server guest virtual machine running in VirtualBox on Linux. The guest uses bridged networking (wired ethernet) and has a static IP address on my network.

I haven't made any changes to any server configurations nor have I installed any updates in the past 30 days. This configuration worked perfectly for the past year until....


A day ago a user discovered that the guest VM has stopped accepting network connections from any other machine, including the host machine. The host interface continues to work perfectly -- I can connect to the host and make outgoing connections from it. The guest can make outgoing connections just fine, including connecting to the Internet and sending packets to other computers. For example, I can access websites from the guest. Also, I can ping my workstation (on the LAN) from the guest, and see the ping packet on Wireshark on my workstation, but the response from my workstation to the guest never makes it there.

What I tried so far

I have tried pinging, connecting on RDP, and connecting through other services. I can still connect through the VirtualBox RDP connection, which doesn't require that networking is functional on the guest OS, so at least I have a way to work in the guest OS while fiddling with network settings.

So far I have tried restarting the guest OS, restarting VirtualBox, and disabling then re-enabling the bridged networking configuration. No luck..

I'm not sure how else to troubleshooting bridged networking. How can I see where the packets are stopping?


My host is headless so I use phpVirtualBox and the command line to manage the guest OS.

UPDATE - Windows Firewall issue not VirtualBox!

I disabled Windows Firewall in my Windows 2008 Server guest and I can get connections now. So this is NOT a VirtualBox bridged networking problem but rather something in Windows 2008 Server that changed on its own. Windows Update shows that no updates have been installed since 2014-12-16, and I've only logged in to check on backups since then.

  • 3
    VirtualBox isn't really suitable for production use. And besides Linux ships with a much better actual hypervisor. My recommendation would be to migrate to it. Commented Jan 13, 2015 at 19:40
  • While it's nice to think about overhauling the infrastructure here, unfortunately I don't have the resources to perform a migration right now just to get this working again. We have 3 users and the services are lightly used. It's been working fine (zero problems) for 1 year in the current configuration and it was on another host machine for the 3 years preceding that, also with zero problems until the host machine hardware failed. Commented Jan 13, 2015 at 19:55
  • I updated the question to reflect that VirtualBox isn't actually the problem here -- Windows 2008 Server has decided to play games with me... Commented Jan 13, 2015 at 22:13
  • FYI, this question was closed one day after I updated it to reflect that I narrowed it down to a Windows 2008 Server Firewall configuration issue. I'm assuming it was closed because I was previously looking into it as a VirtualBox issue? I don't see how a Windows 2008 Server issue would be off topic. Does the question remain off topic in its current iteration? (I'm not asking for it to be reopened..) Commented Jan 21, 2015 at 18:12

1 Answer 1


The profile used by Windows Firewall changed from "Private" to "Public" and the firewall rules were all for "Domain, Private". So when "Public" rules were used, access to services was not allowed.

I'm not exactly sure why this happened, but the WAN router was replaced a week or two ago -- Windows may have taken some time (DHCP lease time?) to reassess the network and decided it wasn't the same one anymore so it defaulted to Public.

Not the answer you're looking for? Browse other questions tagged .