1

Basic premise is that I've created a share and permissioned it up and I can't then change permissions, or even create a folder in it.

Volume: /vol/ProjectData

Share /vol/ProjectData as \netappfiler\Projects

inside OnCommand System Manager I've assigned a domain group for which i am a member as having full control. I expected these to pass through as share permissions and for this to then allow me to set ntfs permissions from computer management on my 8.1 laptop.

so on the share: Everyone - Read Team-Name - Full control

open up windows 8.1 Computer Management, connect to another computer, connect to the Filer

When I try and save the changes I make to the NTFS permissions, I get access is denied. I've seen this article https://www.pickysysadmin.ca/2012/04/27/access-denied-when-changing-ntfs-permissions-on-a-netapp-cifs-share-from-windows… and i wondered if it was something similar. so i used Computer Management on xp and it came back with the same error.

Am I setting my shares up wrongly? Have I missed some super basic config concept out here?

I did however add a qtree to the Share and all of a sudden (inside the qtree) I could create text files and documents. So have I misunderstood the way it works? If I want to permission at NTFS levels, do i need to build something like the following? /vol/Volume/Qtree and then create a share at the Qtree level?

| improve this question | | | | |
  • Can you check whether the volume is set to NTFS security style? – Basil Jan 14 '15 at 11:44
  • do you mean volume? there are no options for permissions styles that I can see in system manager. – bytejunkie Jan 23 '15 at 12:01
  • Right click the volume, edit, and check whether it's set to Unix. If so, change it to NTFS. – Basil Jan 23 '15 at 15:50
  • they're set to mixed currently. ill create a new one and set it up as NTFS and do some testing. – bytejunkie Jan 28 '15 at 10:24
0

Never have volumes or qtrees set to mixed security. Pick either NTFS or UNIX and use that. If you want to be able to have a CIFS shares to a folder with permissions, use NTFS. If you need both concurrent CIFS and NFS connections, pick NTFS. If it's a LUN or a NFS share, pick UNIX.

If you right click a volume in the gui and edit, you should see an option for "security style". This is referring to the default qtree on the volume. Security is a property of a qtree, and each volume contains at least the default qtree. If you have other qtrees, they can be set to anything. NTFS and UNIX in the same volume.

| improve this answer | | | | |
  • 1
    somehow id missed the suggestion in the second paragraoh. twas the solution, so thanks for taking the time to answer such a noob question. – bytejunkie Feb 10 '15 at 21:04
0

If you look at man qtree you'll see there's an option for qtree security with a choice of NTFS, Unix or mixed. You'll need to ensure it's set to NTFS.

| improve this answer | | | | |
  • but does it actually need the qtree is the question I'm asking. – bytejunkie Jan 23 '15 at 12:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.