3

I use apache2 behind nginx on 8 core CPU 48GB RAM server. Now my system uses only 3GB of all memory, but there are high load on CPUs. How can I use my free memory instead of CPUs time?

I also use memcached and xcache.

  • 7
    Your web applications may actually be CPU bound and simply don't need the additional memory... – HBruijn Jan 15 '15 at 14:29
  • Which OS are you running? – TheFiddlerWins Jan 15 '15 at 14:47
1

Well, try allowing more processes to apache. Here are some helpful links:

  • 1
    Link-only answers are discouraged on ServerFault, because if the links go dead the answer won't still be useful. Instead, please describe how the OP should allow more processes in Apache. – Andrew Schulman Jan 15 '15 at 13:10
1

Enable HTTP persistent connections (Keep-Alive) in Apache configuration. In theory this will reduce CPU load (caused by tcp handshaking) and increase memory consumption (in a busy server) as Apache will spawn new worker processes / threads to server new requests.

Of course this is true in a stand alone Apache installation. You have much more variables in your equation (HTTP2 connections, SSL connections, nginx proxy).

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.