I have a Win2k8 guest running on a Fedora 11 system with KVM. For unknown reasons, sometimes when I start the VM, it fails to start in various ways. Sometimes it will bluescreen on boot, sometimes it will allow me to get to the logon prompt and then fail with a message about "mpnotify.exe failed to initialize properly", followed by "the user profile can't be loaded" (that one isn't the exact wording, which I can't get because it's decided it wants to blue screen right now) followed by "logonui.exe failed to initialize properly", and then a black screen that is unresponsive. Interestingly, when it gets into either of these failure modes, safe mode works fine.

The stop error on the blue screen is F4, which I think has something to do with drivers. I've tried removing the HD, IDE, and NIC drivers in safe mode after this happens, but that hasn't fixed it.

The only solution I know of is to restore from backup. Oddly, not all backups fix the error... in fact, the only one that works all the time is the one I took during the installation of the latest service pack, so when it starts up it completes installing the service pack. Also, I used to think that this error only happened when I performed an update on the host system and it updated KVM, but this most recent time happened without a KVM update, AFAIK.

Obviously, this problem is extremely annoying and causes data loss, so I'd appreciate any help!


My KVM command line: sudo qemu-kvm -drive file=c.img,if=ide,index=0,media=disk,cache=writeback -drive file=d.img,if=ide,index=1,media=disk,cache=writeback -m 2200M -smp 4 -vga std -net tap -net nic -localtime

c.img is RAW, d.img is qcow2. As the file names suggest, c.img is my C drive which has Windows on it. When I restore from backup, I only restore the C drive. All my important data is on the D drive, which I have never had trouble with.

  • so, did turning the cache off fix this? – dyasny Aug 17 '10 at 12:37
  • @dyasny: no, in fact it hasn't ever been "fixed". But I haven't had a recurrence in quite some time, probably at least 5 months. I don't know what changed (maybe a system update or something). – rmeador Aug 19 '10 at 21:05

What virtual disk type are you using? qcow2 has some known issues with windows and disk corruption, and the only way to avoid it is to shutdown the caching functions of qemu

please post the kvm command line you are using

I suggest changing the c.img to RAW as well.

qemu-img convert -f qcow2 -O raw c.img c.raw
  • updated question with the info you asked for – rmeador Sep 16 '09 at 21:40
  • changed my answer – dyasny Sep 17 '09 at 10:42
  • you say change C to raw, but C already is raw. Did you mean D? And if so, could you please add why you think that would affect it, since the D drive seems to never have trouble? – rmeador Sep 17 '09 at 13:56
  • ah, my mistake, sorry. change the caching to "off" and try again. this will of course affect performance, but for testing purposes it should be OK – dyasny Sep 17 '09 at 15:48
  • The problem only manifests every few weeks, and only when the VM is restarted, so it will require me running with these non-optimal settings for some time, and even then I can never be certain the problem is gone. Perhaps I'll give that a try when I'm not doing anything performance critical, but I can't try it out right now. Thanks anyways. – rmeador Sep 17 '09 at 16:07

do install on win2k8 gpl driver http://www.meadowcourt.org/WindowsXenPV-0.8.5.zip u can try this

  • since that has Xen in the name, is it xen-only? As I stated in the question, I'm using KVM. What would it do for me? – rmeador Sep 16 '09 at 21:37

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.