I'm getting this error in the main page of phpMyAdmin verson: 3.2.1deb1 The additional features for working with linked tables have been deactivated. To find out why click here. When I click the link I get this report.

$cfg['Servers'][$i]['pmadb'] ...    OK
$cfg['Servers'][$i]['relation'] ...     not OK [ Documentation ]
General relation features: Disabled

$cfg['Servers'][$i]['table_info'] ...   not OK [ Documentation ]
Display Features: Disabled

$cfg['Servers'][$i]['table_coords'] ...     not OK [ Documentation ]
$cfg['Servers'][$i]['pdf_pages'] ...    not OK [ Documentation ]
Creation of PDFs: Disabled

$cfg['Servers'][$i]['column_info'] ...  not OK [ Documentation ]
Displaying Column Comments: Disabled
Bookmarked SQL query: Disabled
Browser transformation: Disabled

$cfg['Servers'][$i]['history'] ...  not OK [ Documentation ]
SQL history: Disabled

$cfg['Servers'][$i]['designer_coords'] ...  not OK [ Documentation ]
Designer: Disabled

I already used the script to create the tables. I assigned the permissions to the pma user. And everything is set in /etc/phpmyadmin/conf.inc.php

But it's still not working... The tables are empty. I assume that they should have something. I'm interested in the relations an history features. Obviously I have read the documentation. Maybe something else is unsetting those values? Any toughs?


You simply need to log out of phpMyAdmin or remove the session cookies and reload once the changes are made.

  • Trying to necroanswer? :-) I wish it was that easy, i tried that too. Too much water passed down the bridge, it's solved now. Dec 15 '09 at 8:39
  • I can't believe that is the solution!
    – etheros
    Dec 16 '09 at 8:17
  • This worked for me. :) Mar 15 '10 at 15:11
  • 2
    wtf. how is THIS the correct answer?? But it worked for me as well. Feb 2 '11 at 19:17
  • Damn! I'd have never had guessed. And I have just spent the last HOUR trying all kinds of deep and dirty mysql tricks. Thanks :)
    – PP.
    May 28 '11 at 11:15

Looking everywhere I ended up editing this file


Nothing related to what I was triyng to do, but I found this comment

# automatically generated by the maintainer scripts of phpmyadmin
# any changes you make will be preserved, though your comments
# will be lost!  to change your settings you should edit this
# file and then run "dpkg-reconfigure phpmyadmin"

So I ran dpkg-reconfigure phpmyadmin despite the fact that it already ran at install time. It asked me if I wanted to recreate the database, my answer was NO.

And now

$cfg['Servers'][$i]['pmadb'] ...  OK
$cfg['Servers'][$i]['relation'] ...  OK
General relation features: Enabled

$cfg['Servers'][$i]['table_info'] ...  OK
Display Features: Enabled

$cfg['Servers'][$i]['table_coords'] ...  OK
$cfg['Servers'][$i]['pdf_pages'] ...  OK
Creation of PDFs: Enabled

$cfg['Servers'][$i]['column_info'] ...  not OK [ Documentation ]
Displaying Column Comments: Disabled
Bookmarked SQL query: Enabled
Browser transformation: Disabled

$cfg['Servers'][$i]['history'] ...  OK
SQL history: Enabled

$cfg['Servers'][$i]['designer_coords'] ...  OK
Designer: Enabled

It's not an upgrade, the table is called pma_column_info and the truth is, I don't care anymore. At least the functions I wanted now are going to work

  • I had the same problem, but $cfg['Servers'][$i]['pmadb'] was initially "not OK". Answering NO in "dpkg-reconfigure" didn't work, but YES did the trick!
    – neu242
    Jul 8 '11 at 19:35

Follow the instructions in Enabling Linked Tables in phpMyAdmin. This solved the same issue in my case!


If you’re getting a message saying

not OK [ Documentation ]”

but the first line ($cfg['Servers'][$i]['pmadb']) says OK, I found that deleting the browser cookies for the phpMyAdmin URL works.

I also switched from

$cfg['Servers'][$i]['auth_type'] = 'cookie';


$cfg['Servers'][$i]['auth_type'] = 'config';

Make sure to set a user and password if you switch to "config".


Do the following will correct the problem.

1) mysql> GRANT USAGE ON mysql.* TO 'pma'@'localhost' IDENTIFIED BY 'pmapass';

2) mysql -uroot -p => to get into MySQL and using commands of scripts/create_table.sql to create a database (phpMyAdmin) and all 9 tables such as:

    ->   DEFAULT CHARACTER SET utf8 COLLATE utf8_bin;
mysql> USE phpmyadmin;
mysql> CREATE TABLE IF NOT EXISTS `pma_bookmark` (
    ->   `id` int(11) NOT NULL auto_increment,
    ->   `dbase` varchar(255) NOT NULL default '',
    ->   `user` varchar(255) NOT NULL default '',
    ->   `label` varchar(255) CHARACTER SET utf8 COLLATE utf8_general_ci NOT NULL default '',
    ->   `query` text NOT NULL,
    ->   PRIMARY KEY  (`id`)
    -> )
    ->   ENGINE=MyISAM COMMENT='Bookmarks'
    ->   DEFAULT CHARACTER SET utf8 COLLATE utf8_bin;

...... and other tables too.

3) mysql> GRANT SELECT, INSERT, UPDATE, DELETE ON phpmyadmin.* to 'pma'@'localhost';

4) Restart MySQL and open the web and the error is gone.


You need to create the structure for the pmadb database. In the scripts directory there is a create_tables.sql to do that. Also check in the file the name of the database if you choose another name.

  • It's the fist thing I did Sep 17 '09 at 19:04
  • Are you sure the script uses the database you configure in config.inc.php? First time I ran the script it creates a phpmyadmin database, but in the config I have pmadb so I need to change the script.
    – hdanniel
    Sep 18 '09 at 3:53
  • it created the tables in phpmyadmin and I configured it in config-db.php Sep 18 '09 at 13:32

It's really annoying when you're sure everything set up as per docs but eventually it doesn't work. Once I had exactly the same stupid problem.

It turned out that I've created user 'pma' but just haven't given it permissions to select-insert-update-delete in the 'phpmyadmin' database. And yes - you need to re-login after these perms have been set.


I just want to add what I did to make the relations feature work on Ubuntu 8.04 LTS Lucid:

  • created empty database phpmyadmin
  • created user pma with pass secret
  • grant privileges
  • $ zcat /usr/share/doc/phpmyadmin/examples/create_tables_mysql_4_1_2+.sql.gz | mysql -u pma -p phpmyadmin
  • entered secret
  • $ sudo vi /etc/phpmyadmin/config.inc.php
  • uncommented:

    /* Authentication type */

    $cfg['Servers'][$i]['auth_type'] = 'http';

    /* Server parameters */

    $cfg['Servers'][$i]['host'] = 'localhost';

    $cfg['Servers'][$i]['connect_type'] = 'tcp';

    //$cfg['Servers'][$i]['compress'] = false;

    /* Select mysqli if your server has it */

    //$cfg['Servers'][$i]['extension'] = 'mysql';

    /* Optional: User for advanced features */

    $cfg['Servers'][$i]['controluser'] = 'pma';

    $cfg['Servers'][$i]['controlpass'] = 'secret';

    /* Optional: Advanced phpMyAdmin features */

    $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';

    $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';

    $cfg['Servers'][$i]['relation'] = 'pma_relation';

    $cfg['Servers'][$i]['table_info'] = 'pma_table_info';

    $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';

    $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

    $cfg['Servers'][$i]['column_info'] = 'pma_column_info';

    $cfg['Servers'][$i]['history'] = 'pma_history';

    $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';


Document written Friday, 8 October 2010

When something is a pain, I should document the solution.

My installation of WAMP on Windows 7 came up with the following 2 red lines in phpMyAdmin.

  1. The additional features for working with linked tables have been deactivated. To find out why click here.

  2. #1045 - Access denied for user 'root'@'localhost' (using password: NO)

Getting rid of the first lot of red text in 3 minutes

From Home in phpMyAdmin, click the Import tab and then click Browse and paste the following location in the filename box.

C:\wamp\apps\phpmyadmin3.2.0.1\scripts , and then select “create_tables.sql” and click “go”.

Open the MySQL console from the WAMP menu and hit enter.

When you are logged on, paste in the next two lines.

CREATE USER ‘phpmyadmin’@'localhost’ IDENTIFIED BY ‘pmapass’;
GRANT SELECT, INSERT, UPDATE, DELETE ON phpmyadmin.* TO ‘phpmyadmin’@'localhost’;

Open WordPad and click Open Document. Paste in the following text to open the file.


Then delete the contents between the PHP tags and paste in the following text.

/* Servers configuration */
$i = 0;

/* Server: localhost [1] */


$cfg['Servers'][$i]['verbose'] = 'localhost';

$cfg['Servers'][$i]['host'] = 'localhost';

$cfg['Servers'][$i]['port'] = '';

$cfg['Servers'][$i]['socket'] = '';

$cfg['Servers'][$i]['connect_type'] = 'tcp';

$cfg['Servers'][$i]['extension'] = 'mysqli';

$cfg['Servers'][$i]['auth_type'] = 'config';

$cfg['Servers'][$i]['user'] = 'root';

$cfg['Servers'][$i]['password'] = '';

$cfg['Servers'][$i]['AllowNoPassword'] = true;

/* User for advanced features */

$cfg['Servers'][$i]['controluser'] = 'pma';

$cfg['Servers'][$i]['controlpass'] = 'pmapass';

/* Advanced phpMyAdmin features */

$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';

$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';

$cfg['Servers'][$i]['relation'] = 'pma_relation';

$cfg['Servers'][$i]['table_info'] = 'pma_table_info';

$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';

$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

$cfg['Servers'][$i]['column_info'] = 'pma_column_info';

$cfg['Servers'][$i]['history'] = 'pma_history';

$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

$cfg['Servers'][$i]['controluser'] = 'phpmyadmin';

$cfg['Servers'][$i]['controlpass'] = 'pmapass';

/* End of servers configuration */

$cfg['DefaultLang'] = 'en-utf-8';

$cfg['ServerDefault'] = 1;

$cfg['UploadDir'] = '';

$cfg['SaveDir'] = '';

Click Save!

Close your browser and open it again, if the error is still there, click refresh and it will be gone.

Getting rid of the second lot of red text

Now set the security for MySQL and get rid of the other error.

If it's open, then close phpMyAdmin.

Open MySQL console from WAMP menu and paste the following two lines.

SET PASSWORD FOR 'root'@'localhost' = PASSWORD('**yourpassword**');FLUSH PRIVILEGES;
SET PASSWORD FOR 'root'@'' = PASSWORD('**yourpassword**');FLUSH PRIVILEGES;*

Hit Enter!

Open “config.inc.php” again and change the following line to enable the same password as above.

$cfg['Servers'][$i]['password'] = '**yourpassword**';

You’re done! Open phpMyAdmin and your red warning text will be gone!

Not the answer you're looking for? Browse other questions tagged or ask your own question.