1

Ran

sudo apt-get update       
sudo apt-get upgrade

Everything was fine. Rebooted. Web server was down. IP not responding to requests on port 80

sudo apachectl start says:

(98)Address already in use: AH00072: make_sock: could not bind to address [::]:80

Which is true, its in use by apache2:

tcp6       0      0 :::80                   :::*                    LISTEN      1124/apache2  

So I tried

sudo apachectl stop
httpd (no pid file) not running

Hmmm, thats odd, its clearly running. If I say:

sudo kill -9 1124

and then

sudo apachectl start 

all is well.

So when bootup triggers apache to start it gets into a hung state where its listening on port 80 but not fully running enough for apachectl commands to work or for it to respond to page requests. But if I kill it and then start it manually all is well. However, after another restart the condition reoccurs.

2
  • Are you sure it wasn't just a process hanging around from before the restart? It's possible that the process didn't die off fully when the upgrade was done. – Andy Smith Jan 18 '15 at 21:23
  • The situation reoccurs after another restart. – AdamG Jan 19 '15 at 0:57
0

Right after startup

ps aux|grep apache

showed that

/usr/share/apache2/ask-for-passphrase localhost:443 RSA

was running which made me realize exactly what was going on.

One of the sites contained an SSL certificate with a passphrase. So when apache was trying to start at boot time it could not continue without someone manually entering the passphrase.

So you have two options to fix this problem:

  1. Add a SSLPassPhraseDialog directive to your config.

  2. Remove your passphrase (Less secure)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.