I deploy Docker containers on Mesos(0.21) and Marathon(0.7.6) on Google Cloud Engine (Ubuntu 14.04).
I use JMeter to test a REST service that run on Marathon. When the concurrent requests are less than 10, it works normal, but when the concurrent requests are over 50, the container is killed and Mesos start another container. I increase RAM, CPU but it still happens.
This is log in /var/log/mesos/

E0116 09:33:31.554816 19298 slave.cpp:2344] Failed to update resources for container 10e47946-4c54-4d64-9276-0ce94af31d44 of executor dev_service.2e25332d-964f-11e4-9004-42010af05efe running task dev_service.2e25332d-964f-11e4-9004-42010af05efe on status update for terminal task, destroying container: Failed to determine cgroup for the 'cpu' subsystem: Failed to read /proc/612/cgroup: Failed to open file '/proc/612/cgroup': No such file or directory
  • Did you look at the docker container logs? – Céline Aussourd Mar 12 '15 at 12:10
  • I had a similar problem when running different apps - when there was not enough ram and cpu and the process tried to allocate more resources, it was killed and restarted (thus cancelling all the active connections). It may be, that you have still not enough resources allocated for the container. – koressak Sep 25 '15 at 11:54
  • 1
    The maximum number of connections in a GCE VM is quite high (130k for small VMs). Therefore this parameter should not be an issue. I believe the right way to go,as previously mentioned,is to examine the container logs.Nevertheless a helpful tool to monitor the resources in your VM is Stackdriver.Additionally checking dmesg could help to discard that the behavior is caused by lack of resources in your VM. I would also recommend trying GKE – Carlos Nov 10 '16 at 18:28
  • If you were able to solve this, you can post self-answer here for other community members who may be seeing this same issue. – Faizan Mar 13 '17 at 22:22

refs: https://issues.apache.org/jira/browse/MESOS-1837


it will resolve your question.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.