0

We are running Exchange 2010. All of my thin clients (Office 2007 - WinServer 2008) and my few PC laptops (Office 2007 - Win7) aren't able to find any recent users that have been added into the directory. One is just a mailbox I've created for a new conference room, and the others are new employees. They do not show up in the global address book and also don't appear when typing in the name and clicking the "Check Names" button.

However, all of my mac users are able to find these users no problem and book time in the new conference room. When I login to webmail and check names, it is able to find the new mailboxes just fine. Any suggestions of what the problem may be would be great! Thanks!

  • How recently were these users added? In Outlook on your PC clients, do you see the mailboxes if you open the Address Book and select the 'live' address list (rather than the Offline list)? – jlehtinen Jan 19 '15 at 21:07
  • 2
    Sync the domain, rebuild the Offline address book then restart outlook on one of the clients. You should now see your new additions. – Optichip Jan 19 '15 at 21:34
  • Some users were created a month ago, some just last week. They were not available when under the "Global Address List." I tried to download the address book and when Outlook was restarted, it still didn't show the new users. – Greg Jan 19 '15 at 22:34
  • And I apologize, the thin clients are running Office 2010. If that makes any difference... – Greg Jan 19 '15 at 22:39
  • All of the PC users were still in cache mode when the email server went down not too long ago. I didn't realize they hadn't gotten out of that yet. Thought we took care of that shortly after it was back up and running. Thanks for all the help though everyone! – Greg Jan 23 '15 at 15:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.