0

I'm setting up a virtual machine running CentOS 7 in a vmware environment, using a vmxnet3 virtual network adapter, and have run into a rather frustrating problem: the interface stops transmitting intermittently, and will not transmit until it has been down/up'd, a la ifconfig eth0 down ifconfig eth0 up

I'm able to ping out until it stops transmitting, but I'm completely unable to ssh. (seperate issue) whether the interface show's as transmitting or not, I'm always able to ping the IP address associated with it. (I assume this is because the IP address is on the host machine, not the guest)

I've tried installing vmware-tools by manually compiling from source, and that corrupted my initrd image, causing me to be unable to load the OS entirely. I've also tried installing open-vm-tools, with the same result.

Anyone have any ideas?

Edit: ESXi 5.5

2nd edit: vSphere Web Client Version 5.5.0 Build 1441077

3rd edit: ESXi build 1331820 is running on the host.

  • What version of ESXi? Build number, please. – ewwhite Jan 19 '15 at 22:56
  • Is this VMWare Desktop? If so what version? Otherwise what version of ESX are you using? Are you using the VSphere interface if so what version? – mdpc Jan 19 '15 at 22:56
  • What specifically makes you think that it's unable to transmit, as opposed to any number of other network problems? Are you seeing a specific error message? – Shane Madden Jan 19 '15 at 22:58
  • @ShaneMadden on ifconfig, the TX Packets statistic stops incrementing completely, but the RX Packet still does. – Oblivious12 Jan 19 '15 at 23:00
1

Upgrade your ESXi installation to a current release. This is one of the reasons it makes sense to keep vSphere and ESXi patched.

https://www.vmware.com/patchmgr/findPatch.portal

Today's release of 5.5 is build 2302651. Your build is over a year old... The version you have is from September 2013.

Once you update your ESXi, then upgrade the VMware tools or install the VMware OSP release of the tools package.

Also see: Can I use Puppet to find out what nodes do not have VMware tools installed?

Edit:

enter image description here

| improve this answer | |
  • 1441077 is the build of the vClient though. How do I see the build of ESXi? Should I be able to view that from my web client? – Oblivious12 Jan 21 '15 at 12:52
  • Hmmm, not sure why you gave the build of the web client. Do you manage the hosts? See my edit above. – ewwhite Jan 21 '15 at 12:58
  • 1331820 is the ESXi build. Can I update the host's ESXi build without disrupting the virtual machines running on it? I don't manage the host, that's another team. :\ – Oblivious12 Jan 21 '15 at 15:03
  • @Oblivious12 Tell your team that they're running a copy of ESXi from September 2013 (which obviously predates RHEL/CentOS 7), and that you're supposed to keep VMware updated... – ewwhite Jan 21 '15 at 15:06
  • 1
    @sepehr I wish I could say I was able to resolve the problem, but given the choice between updating 600+ hosts on the company's vCloud, or going with centos 6.6, they decided that centos 6.6 was the better option. – Oblivious12 Feb 16 '15 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.