2

Today I found myself in a strange situation where my Windows Server 2008r2 machine has internet connection while not showing any connections in 'network connections'. It does not show anywhere in Network and Sharing Center. The strange thing is that when I do ipconfig /all I can see the 'Ethernet adapter Local Area Connection', I can see the 'Realtek PCIe GBE Family Controller' in device manager as well, without any errors. Just not in the network connections panel.

Now there is some errors in the logs:

  1. (multiple times) Driver Management concluded the process to install driver NULL Driver for Device Instance ID ....
  2. (once) Realtek PCI GBE Family Controller: Has encountered a conflict in resources and could not load.

So that got me thinking, hmmm what was I doing yesterday. Yesterday I was assuming the hosting company would add another NIC. I saw 3 devices with troubles in device manager:

  • PCI Simple Communnications Controller
  • SM BUS Controller
  • Universal Serial BUS (USB) Controller

So what I did was the following, I assumed that new hardware was added by the hosting company (which was a wrong assumption) and this would be the PCI Simple Communications Controller. So I tried automatic search for driver software. This failed. Then I figured lets do it manually, and searched for the Realtek PCIe GBE Family Controller drivers on the system so that it would install anyway. This failed. Then I uninstalled the driver for the PCI Simple Communications Controller again and left it like that. That's probably when the problem started to appear...

I have Admin access to the server through RDP.

So conclusion: I have a single network adapter physically, can be seen without errors in ipconfig and device manager but not from Network Connections. How do I get it back there?

  • RealTek NIC on a server? What ungodly brand of server is this? – pauska Jan 20 '15 at 21:42
  • I believe it is an MSI MS-7816. :) – Guido123456789 Jan 20 '15 at 23:30
  • That's a gaming/desktop mainboard, not a server.. – pauska Jan 22 '15 at 7:25
  • Then my boss is probably being scammed. – Guido123456789 Jan 22 '15 at 14:12
2

Never had this issue myself, It's a server, I don't know how far you are willing to go, but here are a couple of possible solutions:

open regedit

Now go to following key:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network

In right-side pane, you'll see a binary key "Config". Select it and press Delete key on your keyboard. You just need to delete Config key.

Refresh the networking connections folder

http://www.askvg.com/fix-network-connections-folder-is-empty-in-windows-not-showing-network-adapters-list/

And this one:

When this key:

HKLM\SYSTEM\CurrentControlSet\Control\Network\Connections\ClassManagers

Has multiple GUID's on a single line, it causes an error and the network connections screen becomes empty, moving them to separate lines fixed his issue.

http://blogs.technet.com/b/juanand/archive/2010/01/11/the-case-of-windows-7-network-connections-empty-folder.aspx

  • This sounds legit and could actually be the cure, I'll give it a try and report the results. Thanks for your input, much appreciated! – Guido123456789 Jan 20 '15 at 21:56
  • Alright, so I removed the config key in HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Network and I confirm this will re-create the config key. However, it does not change a thing. In my procesmanager I see the svhost.exe is working with HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Network so I did the same for this key, with the same result. It does give me some direction to search for solutions, which is nice. – Guido123456789 Jan 20 '15 at 23:28
  • You should not post link-only answers. You should extract the main parts of the links and post them here directly, with a reference to the source. Links can go bust. – MichelZ Jan 21 '15 at 5:53
  • @Guido123456789 aright, sorry these didn't fix your issue, good luck! – RyanTimmons91 Jan 21 '15 at 13:38
0

So I finally solved the problem.

I did various stuff to resolve the problem, for example the registry solutions RyanTommons91 proposed, I compared the registry of 2 identical machines (healthy and unhealthy) which learned me nothing, even installed CCcleaner although I would not recommend doing this on any server system. Nothing seemed to solve the problem.

I saved a final solution for the last attempt because it could potentially break my connection to the server. This solution involved removing the Realtek NIC from device manager, and yes, this broke my connection. So if you are reading this while searching for a solution for your problem, don't forget to schedule the task scheduler to reboot your server. This is what I did and 3 min after the server rebooted my connection was back and the NIC was visible again!

To make the task scheduler reboot your server simply open notepad and type the following:

shutdown -r -f -t 0

(where -r means reboot, -f force programs to close, -t time to wait before start up)

Save the file as reboot.bat in C:\ and create a task in task scheduler to execute this at a specific time in the future.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.