2

My Azure CDN does not appear to be correctly mapped to my Storage Container Blob data.

Storage

I've created a Storage, which is online:

storage

Inside is a Storage Container:

storage-container

My Storage Container has blobs defined, which are functional:

storage-container-blobs

From Visual Studio, I've connected to my Azure via Server Explorer and set the Public Read Access to Container:

container-properties

So, everything seems okay from a Storage perspective.

CDN

Creating a new CDN, it maps from my Storage Origin Domain:

cdn

However, when I try to access blobs via the CDN name or DNS record I have created I simply receive a 404.

cdn-404

One thing I find strange is that the CDN endpoint only gives a 404; whereas the Storage will return json errors. For example, resource not found errors:

Storage endpoint resource not found:

storage-not-found

From the CDN, this will only show 404

cdn-404

It's been a few hours, which should have allowed the CDN to propagate.

Why do my CDN endpoints fail to load Storage?

  • Might be due to [this][1]? When you've configured CDN? [1]: stackoverflow.com/questions/24511070/… – serverstackqns Jan 21 '15 at 8:07
  • I am having major issues since yesterday with Azure CDN. It includes scripts not loading in order now, and now today 404s. – Mike Flynn Jan 25 '16 at 5:22
  • 1
    @MikeFlynn - If you have a new question, post it as a question. You posted a comment to a question from a year ago. – David Makogon Feb 1 '16 at 2:48
  • After a year, did you find the cause? I'm having the same problem here, and after like 3 hours, I'm still getting 404. So, it's not because of cache of course, and blob storage is made public, and I can access it directly via browser, so that's not an issue too. – Saeed Neamati Dec 17 '16 at 17:06
  • @SaeedNeamati No, I could not get it to work, and resorted to using Amazon AWS Cloudfront for CDN. – Jason Sturges Dec 18 '16 at 4:10
1

Make sure you've made your container public. In your Azure portal go to Storage, select your store and then select your 'Containers' tab. From here select the container you want and click 'Edit' from the menu at the bottom. This triggers a popup where you can set your access to public.

  • It's already public, as denoted in container properties. – Jason Sturges Jul 2 '15 at 3:47
0

same answer with keepitreal but with screenshot.

You can simple use Microsoft Azure Storage Explorer. Right Click to container and select Set Public Access Level.

settings image

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.