0

We are scanning to our exchange 2013 server from a scanning application that uses smtp, in the past when the mail exceeded the smtp size limit it would send an email with a link instead of the scanned file, this stopped working possibly after an exchange update, from what I can tell using wireshark the exchange server accepts the job there are no failure codes sent back in the SMTP communication yet an email is sent to the user scanning saying it has exceeded the limit although this is no good for our purpose, why would exchange not sent a exceeded mail limit back during smtp communication? So to summarize: where it used to fail during SMTP comms it now appears to accept and queue the mail then fail it after its queued instead of failing during the SMTP message exchanges. Thanks

0

Exchange only rejects emails that are too large on the SMTP level if you set the size limit in the individual receive connectors instead of on the global level.

Open the Exchange Control Panel, go to the "Mail Flow" option located on the left pane and in the right pane, click on "Receive Connectors". Select the "Default Frontend" receive connector and click on the pencil icon. The "maximum receive size" is right there on the "General" configuration page of the receive connector.

Now if an email is larger than that maximum receive size your Exchange will again reject it directly during the SMTP communication and your scanning application should be able to react correctly.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.