0

So, I created a new DB and my EB app is reaching it fine, but I can't seem to access MySQL from my computer. When I try to run:

mysql --host=123.abc.us-west-2.rds.amazonaws.com –-port=3306 –u myname –p mypass

I just seem to get what you'd see if you did like mysql --help. I've also added "my ip" from the dropdown from going into EC2 > Security Groups > My RDS MySQL entry > Inbound tab > Edit. Added my ip there, saved and tried again but still nothing. I'm not sure what else to try.

I'm brand new to AWS and this is my first RDS / EB app I've done.

  • including the password value on the command line can be a security risk. To avoid this problem, specify the --password or -p option without any following password value: shell> mysql --host=localhost --user=myname --password mydb shell> mysql -h localhost -u myname -p mydb When the password option has no password value, the client program prints a prompt and waits for you to enter the password. – ADM Jan 23 '15 at 11:15
1

Do you have your RDS instance in a VPC? Are you sure that your RDS instance has the "Publicly Accessible" setting set to "Yes"?

If you want to be able to access your RDS instance from outside your VPC, you need to switch that option to "Yes".

  • I believe it's VPC. In the details of my instance it says "VPC: vpc-{ID HERE}" and "Publicly Accessible" says "Yes" – Oscar Godson Jan 23 '15 at 18:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.