2

I have UAC disabled on my Windows 2008R2.

Why am I still getting UAC "Windows needs your permission to continue" window before trying to change Owner of a folder?

My user is a member of the Administrators group

Thanks

Update: I forgot to mention that Windows 2008R2 server is a member of a domain controlled by a Windows 2003R2 server. Is that normal?

5

You also need to disable Admin Approval Mode

Disable Admin Approval Mode

To disable AAM

Start>Run> Type "secpol.msc">hit enter

In the interface double click Local Policies> double-click Security Options.

Scroll down and double-click User Account Control: Run all administrators in Admin Approval Mode.

Select the Disabled option, and then click OK.

There are also other options you can disable to prevent UAC from getting in our way but I believe AAM is what you may be getting now.

  • Thanks for pointing me to this option. It's currently set to "Not defined". Do I still need to disable it? – Bibi195 Jan 26 '15 at 18:04
  • Since it's 2008 and you have disabled it via GUI it shouldn't effect the outcome but it wouldn't hurt to disable it to ensure you have that setting locked in. – Citizen Jan 26 '15 at 18:15
  • Do I need to restart after setting AAM? – Bibi195 Jan 26 '15 at 18:24
  • Yes, it's a local policy and get's processed on startup. – Citizen Jan 26 '15 at 18:37
  • 1
    I've scheduled a system restart on the weekend. Hopefully it will help. – Bibi195 Jan 27 '15 at 1:43
0

Can't Comment yet...But:

What is the exact wording of your UAC setting? There are a few different levels, and some of them are stupid.

Also have you done a GPupdate, and a restart between disabling UAC and attempting to change permissions?

  • 1
    This is Windows 2008R2. I have only one option Use User Account Control (UAC) to help protect your computer. I did restart several times but I'm not sure GPupdate was done. While I'm typing it I'm thinking I may have forgotten to mention an important fact - the domain controller is Windows 2003R2. Could it have contributed to this mess? – Bibi195 Jan 25 '15 at 21:55
  • if you do a gpudate /force it will make the local security policy apply. – Citizen Jan 27 '15 at 5:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.