0

Up until recently we have had two Windows Server 2003 Domain Controllers and five Windows Server 2003 Terminal Servers. I'm in the process of upgrading the network and have recently replaced the DC's with two Windows Server 2012 R2 DC's. The original plan was to also use Windows 2012 R2 to create seven Remote Desktop Servers, however, our thin clients do not utilize RDP 6.0 and I have been forced to user Windows Server 2008 R2. I have one server up and running for testing purposes but I have not been able to remove the Powershell and Server Manager icons from the users' taskbars. I've Googled and have found several write-ups (like this one http://www.woutermakkinje.com/?p=148 and this one http://www.emware.nl/articles/remove-unpin-powershell-icon-from-taskbar.html ) but so far neither have worked.

I think it may have to do with the differences in folder location/availability in 2012 vs. 2008. The tutorials linked above have you drill down to "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Accessories\Windows PowerShell\Windows PowerShell.lnk" - this location exists in 2008 but not in 2012 so when I attempt to drill down on the DC I can only make it to "C:\ProgramData\Microsoft\Windows\Start Menu\Programs\". I can find the Powershell and Server Manager shortcuts in that path by continuing on to "\Administrative Tools\" but adding the shortcuts I find in that directory does not disable the icons.

I know that the users shouldn't be able to run anything (and Server Manager does tell a regular user they are restricted when they attempt to run it) but I would rather not have these icons available at all.

  • I'll give that a shot. I forgot to mention in my original post that the reason I'm trying to remove those specific icons through group policy is that I was trying to avoid using the policy for "Remove pinned programs from the taskbar" - that way users could still pin shortcuts that they wanted (Outlook, Excel, Word, etc., etc.) – quicksilver Jan 26 '15 at 18:01
  • This is the correct path you choose then, as without permission the winlogon process will be unable to create those icon on profile creation.On existing login it's the first path, as the icon are already created. – yagmoth555 Jan 26 '15 at 18:33
1

Try that location too: %APPDATA%\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar

And try with the %AllUsersProfile% variable for the location you named:

%AllUsersProfile%\Microsoft\Windows\Start Menu\Programs\Accessories\Windows PowerShell\Windows PowerShell.lnk

%AllUsersProfile%\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Server Manager.lnk

%AllUsersProfile%\Microsoft\Windows\Start Menu\Programs\Administrative Tools\Windows PowerShell Modules.lnk

You need to remove the permission from those icon to keep there only admin

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.