2

I'm connecting to my server (Centos 7) with ssh and I try to ping to localhost: ping 127.0.0.1 but doesn't work:

ping 127.0.0.1

PING 127.0.0.1 (127.0.0.1) 56(84) bytes of data.
^C
--- 127.0.0.1 ping statistics ---
78 packets transmitted, 0 received, 100% packet loss, time 76999ms

Here my files. networks:

default 0.0.0.0
loopback 127.0.0.0
link-local 169.254.0.0

hosts:

# nameserver config
# IPv4
127.0.0.1 localhost.localdomain localhost
1xx.xxx.xxx.xxx  server
#
# IPv6
::1     ip6-localhost ip6-loopback
...

lo route:

DEVICE=lo
IPADDR=127.0.0.1
NETMASK=255.0.0.0
NETWORK=127.0.0.0
# If you're having problems with gated making 127.0.0.0/8 a martian,
# you can change this to something else (255.255.255.255, for example)
BROADCAST=127.255.255.255
ONBOOT=yes
NAME=loopback

I need make a ping! What I can do?

11
  • maybe bring up local interface : ifup lo ?
    – Nico
    Jan 26 '15 at 14:48
  • Is currently UP :/
    – Neil
    Jan 26 '15 at 14:49
  • 1
    Check routes, firewall, iptables ? Do you have a resolv.conf ? If no, please create one for testing purpose at least
    – Nico
    Jan 26 '15 at 14:50
  • Also check if /proc/sys/net/ipv4/icmp_echo_ignore_all is set to 0 if it exists.
    – Nico
    Jan 26 '15 at 14:52
  • 1
    try setting it to 0 with echo 0 > path_to_file. Guess its the cause
    – Nico
    Jan 26 '15 at 15:02
3

After checking that local interface is up (ifup lo0 or similar).

Check for routes, firewall or iptables problem.

Here it was a problem from the file located here /proc/sys/net/ipv4/icmp_echo_ignore_all
When set to 1 : There is no response to ICMP Requests, so ping will not work.
When set to 0 : Replies to ICMP Requests are enable.

Check if sets to 1. If so, set it to 0 by using this command : echo 0 > /proc/sys/net/ipv4/icmp_echo_ignore_all

Now, your machine replies to ping.

1
  • 2
    Did you accidently switch 0 and 1 in the first part of your answer? Jan 26 '15 at 19:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.