2

I'm trying to create Backup Schedule from my local drive on a network share but Windows Server 2012 won't let me. I get the error "The parameters are incorrect". When I try the "Backup Once" with all the same settings it just works...

After a few search on the internet, I've found that the Backup Schedule needs to run using the local administrator user. Then I found the backup schedule is using "wbadmin" and that it would use the "Volume Shadow Copy" local service so I tried to edit that service to "Log on" as a local admin but no luck (it's even worst because it fail faster with the same error).

So I tried to find another solution which was to open a terminal and manually try the wbadmin command line (without the Windows Backup Server GUI) so it could run with the administrator user, and then add a scheduled task with the local administrator etc (sounds fair).

BUT, when I open the command line and try to do this command, it just fail saying I get a command syntax incorrect. Error: -addtarget:\\NAS\Backup:

wbadmin enable backup –addtarget:\\NAS\Backup –include:c:\TestBackup –user:\OutsideDomainUser –password:MyPassword –schedule:22:00

I'm pretty sure the command is OK as I got it directly from the Microsoft doc right here (it's Senario #2): Wbadmin enable backup

Can someone help me to make the GUI or the wbadmin command to work correctly using a network share as destination.

0

Your syntax is correct.

Assuming the target you want to add is reachable, then this error message concerns any of the previously added targets. Check the targets using:

wbadmin get disks

and make them available or remove them (-removetarget)

Look here for "Error message when you try to add an additional disk to a scheduled backup ..." by Microsoft.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.