2

I have HP Proliant G5 series with license for iLO2.

The server is running CentOS. Telnet ports are opened and I can successfully connect via certain port, that i've set up in iLO2 setting to use for Remote Access\Telnet.

However no matter what I try i seem not be able to connect via remote console no matter which service I use be it ActiveX or JVM.

When I try to connect via ActiveX it says that the following message "Failed to connect to server. Check for available telnet connection."

If I try it using the JVM i get the following Error:

ClassNotFoundException
com.hp.ilo2.remcons.remcons.class

I have the most updated version of the iLO2 v2.25 and I tried everything from using the different version of JVM and browser to almost anything.

Any idea what could be my next step? I however don't have anything installed on the server regarding software for ilo2 but from my understanding there is no software needed since the iLo hooks directly on screen and input devices.

  • Is there a firewall between you and the server? – ewwhite Jan 27 '15 at 17:25
  • 1
    There is but the SSL and Remote Console / Telnet ports are properly forwarded through different ports and are altered in the ilo2 config accordingly. I can connect via telnet easily into ilo over the internet, so that port works 100%. – sumone Jan 27 '15 at 19:08
0

For help with the ClassNotFoundException "com.hp.ilo2.remcons.remcons.class" error, see "Investigating/Fixing HP ILO2 Java Remote Console fails to start with Class Not Found remcons.class" from framer99 Link Here. This fixed the problem for me on my older HP servers.

  • Will check it out and post a feedback. Currently i'm busy on some other project and don't have the time to test it. Thanks for helping. – sumone May 18 '15 at 19:51
  • Whilst the link provided may answer the question, we generally prefer you at least summarize the fix here too. That way, if the link ever goes stale, the solution is still around. Thanks! – Falcon Momot Oct 6 '15 at 0:14
  • Also it is worth mentioning that 2.29+ addresses this issue. More info: h20565.www2.hpe.com/hpsc/doc/public/… – sumone Apr 26 '16 at 18:34
2

The ports needed are 443 to login to the iLO plus 17990 and 80. At least it did the same nothing i.e. did not work when port 80 was not forwarded and then .NET console worked with port 80 forwarded. BTW, to work this out I just ran a netstat from a LAN client that was able to connect the remote console.

1

Please check to see that you have the following ports open between you and the ILO's network:

====================
22 Secure Shell (SSH)
23 Remote Console / telnet
80 Web Server Non-SSL (HTTP)
443 Web Server SSL (HTTPS)
3389 Terminal Services
17988 Virtual Media
9300 Shared Remote Console
17990 Console Replay
3002 Raw Serial Data

In reality, you really just need 23, 443 and 17990... But you should be able to nmap the ILO and see these ports open.

  • I thought that for a successful connection via remote console there is only one port needed to be opened - the Remote Console / Telner port - I have it set up correctly via different port number. Also I have set up a different port number for https. The only one I don't have is for "Console Replay". Is this one needed for successful connection? – sumone Jan 27 '15 at 18:48
  • @sumone Yes. You need 17990. – ewwhite Jan 27 '15 at 19:52
  • Forwarded port for Console Replay and still the same message appears. – sumone Jan 30 '15 at 19:57
  • Sorry. You can ssh to the ILO and use the textcons command. Or just VPN into that network and forget the port forwarding game. – ewwhite Jan 30 '15 at 20:40
  • All bets are off if you've modified the ports used by the ILO in its configuration. I'm not sure what you've done here. – ewwhite Feb 1 '15 at 20:26
0

This is fixed in 2.25+ version of ILO2 firmware.

  • According to the question he already tried v2.25. – kasperd Feb 7 '16 at 20:13
  • Well, I had the same problem too, with ILO2 on 360 G5. Permissions were added in the jar in the 2.25, the error with missing class was fixed probably later. 2.29 solved the issue for me, not sure what minimal version is required to run now. – drookie Feb 8 '16 at 6:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.