0

I am using a Windows Server 2012 R2 as Domain Controller, DHCP Server, DNS in my network. My Router is the gateway which is connected to the DSL modem.

Some Clients (all android devices) and the amazon kindle (which i think is android based as well) do not have internet access with DHCP enabled. Windows Clients, a MAC Mini, iPad and IPhone don't have any problems to access the internet, all with dhcp enabled.

If i set a static ip on the failing devices with all options manually (gateway and dns) everything is fine. So it seems to be definitly a problem of DHCP.

In DHCP options i have the following settings
Router Option 3 with the gateway address
DNS Server Option 6
DNS-Domain-Name Option 15

The following network setup

Windows Server: 10.0.1.2
Gateway: 10.0.1.1 (connected as 10.0.0.x to the modem)
Modem: 10.0.0.138
Clients: 10.0.1.100-200 = DHCP range
DHCP on Gateway router is deactivated.

NetScan shows only one dhcp server responding with the correct Gateway and DNS settings.

I can't find out whats wrong, i don't believe its a general Android problem with windows server.

Does anyone have any ideas or suggestions to solve the problem?

The failing devices seem to get a valid IP from DHCP, it seems not to be a DNS Problem, i think the gateway is not found correctly.

  • I'm not understanding some of your information. What does this mean? Gateway: 10.0.1.1 (connected as 10.0.0.x to the modem). What is the LAN ip address of the modem and is the network connected directly to the LAN interface of the modem? Modem: 10.0.0.138 is that the external (WAN) interface? What subnet mask are you using? – joeqwerty Jan 27 '15 at 21:16
  • the router has the LAN IP 10.0.1.1 and the WAN side IP 10.0.0.6, this address it gets from the DHCP of the modem which has 10.0.0.138. the router is connected WAN side to the lan port of the modem directly. Subnet Mask is 255.255.255.0 on client, server and router. – loiti Jan 27 '15 at 21:28
  • Is there a trace route tool you can run on the Android or Kindle to trace the route to an external ip address, like 8.8.8.8 to see what path it's taking? – joeqwerty Jan 27 '15 at 21:32
  • the modem gets the dynamic external ip on WAN Side from the ISP. – loiti Jan 27 '15 at 21:32
  • i am not an android specialist, the android devices are phones. is there any app you can recommend from the google play store? i have no root access to the android phone. – loiti Jan 27 '15 at 21:34
0

What you can do on the Android devices:

Network Tools can do a traceroute.

ipconfig will show you more network settings (like the gateway and lease duration) than the standard menus.

See what those settings are to determine whether DHCP is handing out the correct info or not.

If it looks like the device does have all the correct info (same as when you manually apply it and it works) then do the traceroute and see if that reveals anything about what the device is doing.

What you can do on the DHCP server:

In the DHCP manager, right click on IPv4, choose Properties, then go to the Advanced tab. You should see an Audit log file path which defaults to %WinDir%\system32\dhcp.

In that folder you should have detailed logs, one for each day of the week. That should help you determine what's going in a particular request.

In Event Viewer, browse to Applications and Services Logs > Microsoft > Windows > DHCP-Server. The logs in here show errors related to specific MAC addresses and requests, could be helpful.

In DHCP manager, under IPv4, check Filters and Policies to see if you have anything set in there that might be excluding Android devices (or any other settings that look interesting). For example, all android devices have a hostname that begins with Android- so you could create a policy that gives any client with an FQDN beginning with Android a different router.

Have you posted all of the DHCP options in effect (global and scope)?

  • Thanks for the recommended very helpful tools. Everything looks good in traceroute and ipconfig. First ip in traceroute is my gateway 10.0.1.1, the next the modem 10.0.0.138 and then all the external hops. the information in ipconfig looks good. It is working with activated DHCP on android clients now. I haven't tried it for a few days. the only thing i changed in the scope: i added a static route 0.0.0.0 255.255.255.255 to 10.0.1.1 I am not sure if that solved the issue - i found this hint in some forums where people are in the opinion that android did not implement a RFC correctly. – loiti Jan 30 '15 at 18:22
  • Lots of information provided on the site, there seems to be a problem with the lease. this could also solved my problem, because i got a new ip with a new lease. – loiti Jan 30 '15 at 19:48
1

I have the same setup, with a Windows Server 2012 R2 unit running as the DNS Server, DHCP server and domain controller.

Two office-use Android tablets worked fine on the traditional network (normal router running as DHCP server, ISP DNS) before we switched to a Domain. I tried a bunch of different things but the only solution that worked was to do the following:

  1. Open the DCHP server MMC on the Server.
  2. Under the IPv4 branch, right-click 'Reservations'.
  3. Create a static IP (in line with your IP structure) for each Android device (you can get the MAC from each device easily if they are already connected to the network - they will show in the Address Leases list)
  4. On each device, modify the DNS (Click/hold on the wifi network > Modify > Change DHCP to 'Static', enter your assigned IP, then scroll down and add 8.8.4.4 (or any other public one) as the secondary DNS server).
  5. Reconnect to the network to refresh the settings.

I have three devices now working with this change. A bit of a pain to do, but once it's done it will hold the settings, and as a bonus it keeps your DHCP pool cleaner without the devices pulling from it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.