3

I am at my wits end... Newbie to Linux... please help me...

Goal is to connect to MS SQL Server 2005 using PHP. I have installed PHP and ODBC. I am running CentOS7.

PHP Version => 5.4.16

.... (from php -i) ....

odbc

ODBC Support => enabled

I am running into 2 dependency issues when trying to install freetds and php-mssql extension. (see below)

[root@localhost freetds-dev.0.92.377]# yum install php-mssql freetds
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: mirror.supremebytes.com
 * epel: mirror.sfo12.us.leaseweb.net
 * extras: mirrors.cat.pdx.edu
 * rpmforge: mirror.hmc.edu
 * updates: ftp.osuosl.org
Resolving Dependencies
--> Running transaction check
---> Package freetds.x86_64 0:0.91-2.el6 will be installed
--> Processing Dependency: libgnutls.so.26(GNUTLS_1_4)(64bit) for package: freetds-0.91-2.el6.x86_64
--> Processing Dependency: libgnutls.so.26()(64bit) for package: freetds-0.91-2.el6.x86_64
---> Package php-mssql.x86_64 0:5.3.3-3.el6 will be installed
--> Processing Dependency: php(zend-abi) = 20090626 for package: php-mssql-5.3.3-3.el6.x86_64
--> Processing Dependency: php(api) = 20090626 for package: php-mssql-5.3.3-3.el6.x86_64
--> Finished Dependency Resolution
Error: Package: freetds-0.91-2.el6.x86_64 (epel)
           Requires: libgnutls.so.26()(64bit)
Error: Package: php-mssql-5.3.3-3.el6.x86_64 (epel)
           Requires: php(api) = 20090626
           Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates)
               php(api) = 20100412-64
           Available: php-common-5.4.16-21.el7.x86_64 (base)
               php(api) = 20100412-64
           Available: php-common-5.4.16-23.el7_0.x86_64 (updates)
               php(api) = 20100412-64
           Available: php-common-5.4.16-23.el7_0.1.x86_64 (updates)
               php(api) = 20100412-64
Error: Package: freetds-0.91-2.el6.x86_64 (epel)
           Requires: libgnutls.so.26(GNUTLS_1_4)(64bit)
Error: Package: php-mssql-5.3.3-3.el6.x86_64 (epel)
           Requires: php(zend-abi) = 20090626
           Installed: php-common-5.4.16-23.el7_0.3.x86_64 (@updates)
               php(zend-abi) = 20100525-64
           Available: php-common-5.4.16-21.el7.x86_64 (base)
               php(zend-abi) = 20100525-64
           Available: php-common-5.4.16-23.el7_0.x86_64 (updates)
               php(zend-abi) = 20100525-64
           Available: php-common-5.4.16-23.el7_0.1.x86_64 (updates)
               php(zend-abi) = 20100525-64
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have libgnutls.so version 28 though

/usr/lib64/libgnutls.so.28
/usr/lib64/libgnutls.so.28.20.4

I have been trying to figure this out for 4 days and I am very frustrated. Any help would be super appreciated. Thanks in advance.

3

You installed the EPEL repository for EL6, but you are running EL7. Remove it and try again with the correct EPEL version.

  • 1
    Ok just removed (yum remove epel-release) and installed (yum install epel-release) Installed: epel-release.noarch 0:7-5 but still same result. – DylanH Jan 28 '15 at 2:01
  • I think my inexperience has led me to reinstall the wrong thing. Googling your suggestion now. – DylanH Jan 28 '15 at 2:05
  • 1
    So now I have EPEL 7-5 installed (for Linux 7). Running the yum install php-mssql freetds still produces the same dependency issues. Is there anything you can think of I should be doing (or doing wrong). Thanks again for the help. – DylanH Jan 28 '15 at 2:21
  • That's not very likely, unless you've done something to your system other than what you've already said. I suggest you start over. – Michael Hampton Jan 28 '15 at 2:39
  • Thank you, finally got this working, I used yum remove epel-release rpm --rebuilddb then yum install epel-release – DylanH Jan 28 '15 at 21:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.