1

I'm trying to figure out which ports I have to open on my MSSQL-Server to let the SCOM (System center operations manager) connect successfully.

I've tried:

disable the domain network firewall -> SCOM successfully connect.

new rule allow TCP inbound ports 1-65535 -> SCOM successfully connect.

If I just enable port 1433,1434 no connection can be established (from Technet.microsoft)

Which ports do I have to open?

I'm using SCOM 2012 with MSSQL 2014 on win Server 2012R2

4
  • Have you tried to telnet port 1433 to verify that your firewall rule is set up correctly? Are you sure no-one changed the default ports? – Reaces Jan 28 '15 at 13:14
  • ive installed telnet server and client. telnet does not work using command telnet msql-server 1433. neither does when both firewalls are disabled. neither does on default port 23. i just installed mssql as well as scom, with all default values. im using a named instance on mssql server – Joel Jan 28 '15 at 13:28
  • Are you currently trying to install SCOM? Or are you talking about having a SCOM agent on the SQL server connect back to the SCOM Management Server? – Jacob Jan 30 '15 at 7:01
  • Im installing SCOM, in the installation process i disabled the firewall. success. then enabled firewall, set the port rules, started OpearionsManager (running on another virtual machine), and it said: "connection to server" forever. – Joel Jan 30 '15 at 7:50
2

Since 2008, SQL Server answers on dynamic ports by default. You can set static ports in SQL Server Configuration Manager.

To turn Dynamic Ports off, erase the 0 that appears on the right side, above the port number (in this case, 1433).

Once you have static ports, you'll need to enable access to 1433 TCP and 1434 UDP.

enter image description here

2
  • i did configure it as you said, restarted the mssql-server. no success. do i have to "enable" IP1 & IP2, because now it is set to enabled - no? – Joel Jan 30 '15 at 7:48
  • the connetion cannot be establish. The Operations Manger Console says "connection to Server", until i disable the Firewall at my MSSQLserver. – Joel Jan 30 '15 at 14:44
2

I had to configure the static ports for IP1, IP2, IPAll, Erase the 0 at Dynamic Ports and set TCP Ports to 1433, however, Im using a named instance.

also open firewall ports

Once you have static ports, you'll need to enable access to 1433 TCP and 1434 UDP. (Katherine Villyard)

See Screen Shots for configuration details.

Configuration 1 Configuration 2

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.