2

I realize that DSML Services for Windows lists Windows 2000 or Windows Server 2003 as a requirement, but can anybody tell me if it will still run on Windows Server 2008? We're using DSML to talk to our Active Directory server, and since 2003 is losing support, we want to upgrade the servers AD and the DSML support are running on.

We'd really like to avoid retooling our security service to stop using DSML if at all possible.

Any insight would be appreciated. Thanks.

2

It does, yes. It even installs and runs on Server 2008 R2.

Having said that, the service itself has been deprecated, so you're going to run into out-of-support issues with DSML even if you move it to a newer OS platform.

The current Microsoft solution for communication with AD over web protocols is ADWS (Active Directory Web Services), which you will probably need to migrate your current DSML setup to at some point. But, at least for the near future, you can run DSML on a supported OS platform.

  • Great, thanks. I realize we have to move off of DSML, but the IT guys are telling us we have a hard date for that because the DSML module won't work on 2008. That seems to not be the case, meaning we can be more flexible in migrating off of it. – Michael Oryl Jan 28 '15 at 20:16
  • 1
    @MichaelOryl Just to be clear, I'm only saying that the DSML Services for Windows that Microsoft puts out will install and run on Server 2008/2008 R2. That's not a guarantee that your code and modules will as well. It's a good sign, but something you should verify and test for yourself, to be sure. – HopelessN00b Jan 28 '15 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.