1

I created a mail server, following this tutorial:
https://www.linode.com/docs/email/postfix/email-with-postfix-dovecot-and-mysql ,

I configured the email on my email client, SMTP and IMAP and both connections are working, I can send email from my email address (example@domain.com) to another (example@gmail.com) and i can read it as well, but when I send to email address of my email server (example@domain.com), it sends, but I do not see it in inbox of example@domain.com...

Created a mx record: example.com mx 10 example.com
and created a spf record too: v=spf1 a mx ~all

The mail server is on Ubuntu 14.04.1 Desktop.

The results of dovecot -n

# 2.2.9: /etc/dovecot/dovecot.conf
# OS: Linux 3.13.0-44-generic x86_64 Ubuntu 14.04.1 LTS ext4
auth_mechanisms = plain login
mail_location = maildir:/var/mail/vhosts/%d/%n
mail_privileged_group = mail
namespace inbox {
  inbox = yes
  location = 
  mailbox Drafts {
    special_use = \Drafts
  }
  mailbox Junk {
    special_use = \Junk
  }
  mailbox Sent {
    special_use = \Sent
  }
  mailbox "Sent Messages" {
    special_use = \Sent
  }
  mailbox Trash {
    special_use = \Trash
  }
  prefix = 
}
passdb {
  args = /etc/dovecot/dovecot-sql.conf.ext
  driver = sql
}
protocols = imap pop3 lmtp
service auth-worker {
  user = vmail
}
service auth {
  unix_listener /var/spool/postfix/private/auth {
    group = postfix
    mode = 0666
    user = postfix
  }
  unix_listener auth-userdb {
    mode = 0600
    user = vmail
  }
  user = dovecot
}
service imap-login {
  inet_listener imap {
    port = 0
  }
}
service lmtp {
  unix_listener /var/spool/postfix/private/dovecot-lmtp {
    group = postfix
    mode = 0600
    user = postfix
  }
}
service pop3-login {
  inet_listener pop3 {
    port = 0
  }
}
ssl = required
ssl_cert = </etc/dovecot/dovecot.pem
ssl_key = </etc/dovecot/private/dovecot.pem
userdb {
  args = uid=vmail gid=vmail home=/var/mail/vhosts/%d/%n
  driver = static
}

Results of netstat -panet:

tcp        0      0 0.0.0.0:995             0.0.0.0:*               ESCUTA      0          11309       986/dovecot     
tcp        0      0 0.0.0.0:7300            0.0.0.0:*               ESCUTA      1001       13485       1371/perl       
tcp        0      0 192.168.1.104:27754     0.0.0.0:*               ESCUTA      1001       13484       1371/perl       
tcp        0      0 127.0.0.1:3306          0.0.0.0:*               ESCUTA      117        11024       1134/mysqld     
tcp        0      0 0.0.0.0:587             0.0.0.0:*               ESCUTA      0          11611       1232/master     
tcp        0      0 0.0.0.0:465             0.0.0.0:*               ESCUTA      0          11617       1232/master     
tcp        0      0 127.0.1.1:53            0.0.0.0:*               ESCUTA      0          12148       1486/dnsmasq    
tcp        0      0 0.0.0.0:21              0.0.0.0:*               ESCUTA      0          9546        993/vsftpd      
tcp        0      0 0.0.0.0:22              0.0.0.0:*               ESCUTA      0          9555        980/sshd        
tcp        0      0 127.0.0.1:631           0.0.0.0:*               ESCUTA      0          8840        510/cupsd       
tcp        0      0 0.0.0.0:25              0.0.0.0:*               ESCUTA      0          11602       1232/master     
tcp        0      0 127.0.0.1:6010          0.0.0.0:*               ESCUTA      1000       21171       3082/1          
tcp        0      0 0.0.0.0:993             0.0.0.0:*               ESCUTA      0          10582       986/dovecot     
tcp        0      0 192.168.1.104:993       85.242.102.178:50794    ESTABELECIDO 119        24686       3168/imap-login 
tcp        0      0 192.168.1.104:7300      78.111.205.56:45853     ESTABELECIDO 1001       21084       1371/perl       
tcp        0      0 192.168.1.104:993       85.242.102.178:55965    ESTABELECIDO 119        21384       3176/imap-login 
tcp        0    264 192.168.1.104:22        192.168.1.90:57457      ESTABELECIDO 0          21118       3046/sshd: diogosar
tcp        0      0 192.168.1.104:993       85.242.102.178:57359    ESTABELECIDO 119        21396       3178/imap-login 
tcp6       0      0 :::995                  :::*                    ESCUTA      0          11310       986/dovecot     
tcp6       0      0 :::587                  :::*                    ESCUTA      0          11612       1232/master     
tcp6       0      0 :::80                   :::*                    ESCUTA      0          10956       1340/apache2    
tcp6       0      0 :::465                  :::*                    ESCUTA      0          11618       1232/master     
tcp6       0      0 :::22                   :::*                    ESCUTA      0          9557        980/sshd        
tcp6       0      0 :::25                   :::*                    ESCUTA      0          11603       1232/master     
tcp6       0      0 ::1:6010                :::*                    ESCUTA      1000       21170       3082/1          
tcp6       0      0 :::993                  :::*                    ESCUTA      0          10583       986/dovecot   

My question is: Why I see no inbox on email, if I send emails to it? I tried with POP3 too...

Update:

File excerpt: /var/log/mail.log:

Jan 29 15:07:43 Ubuntu postfix/error[3196]: AA1E22C3528: to=<cr7akg@cr7akg.com>, relay=none, delay=59795, delays=59795/0.06/0/0, dsn=4.4.2, status=deferred (delivery temporarily suspended: lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:11:03 Ubuntu postfix/scache[3193]: statistics: start interval Jan 29 15:07:43
    Jan 29 15:11:03 Ubuntu postfix/scache[3193]: statistics: domain lookup hits=0 miss=2 success=0%
    Jan 29 15:12:43 Ubuntu postfix/qmgr[3157]: 225BE2C3568: from=<cr7akg@cr7akg.com>, size=519, nrcpt=1 (queue active)
    Jan 29 15:12:43 Ubuntu dovecot: lmtp(3217): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given
    Jan 29 15:12:43 Ubuntu postfix/lmtp[3216]: 225BE2C3568: to=<cr7akg@cr7akg.com>, relay=Ubuntu[private/dovecot-lmtp], delay=58634, delays=58634/0.03/0.01/0, dsn=4.4.2, status=deferred (lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:17:43 Ubuntu postfix/qmgr[3157]: 083672C3576: from=<ea6vq@dxmaps.com>, size=697, nrcpt=1 (queue active)
    Jan 29 15:17:43 Ubuntu dovecot: lmtp(3225): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given
    Jan 29 15:17:43 Ubuntu postfix/lmtp[3224]: 083672C3576: to=<cr7akg@cr7akg.com>, relay=Ubuntu[private/dovecot-lmtp], delay=57731, delays=57731/0.03/0.01/0, dsn=4.4.2, status=deferred (lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:20:52 Ubuntu dovecot: imap-login: Login: user=<cr7akg@cr7akg.com>, method=PLAIN, rip=85.242.102.178, lip=192.168.1.104, mpid=3232, TLS, session=<wzqYCMwNSQBV8may>
    Jan 29 15:22:43 Ubuntu postfix/qmgr[3157]: 369702C3665: from=<>, size=2930, nrcpt=1 (queue active)
    Jan 29 15:22:43 Ubuntu postfix/qmgr[3157]: F0A022C3538: from=<diogoandresaraiva@me.com>, size=1260, nrcpt=1 (queue active)
    Jan 29 15:22:43 Ubuntu postfix/qmgr[3157]: 0A11C2C3581: from=<cr7akg@cr7akg.com>, size=525, nrcpt=3 (queue active)
    Jan 29 15:22:43 Ubuntu dovecot: lmtp(3654): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given
    Jan 29 15:22:43 Ubuntu dovecot: lmtp(3657): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given
    Jan 29 15:22:43 Ubuntu postfix/lmtp[3652]: 369702C3665: to=<cr7akg@cr7akg.com>, relay=Ubuntu[private/dovecot-lmtp], delay=30046, delays=30046/0.03/0.01/0, dsn=4.4.2, status=deferred (lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:22:43 Ubuntu postfix/lmtp[3653]: F0A022C3538: to=<cr7akg@cr7akg.com>, relay=Ubuntu[private/dovecot-lmtp], delay=21441, delays=21441/0.02/0.01/0, dsn=4.4.2, status=deferred (lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:22:43 Ubuntu dovecot: lmtp(3660): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given
    Jan 29 15:22:43 Ubuntu postfix/lmtp[3652]: 0A11C2C3581: to=<cr7akg@cr7akg.com>, relay=Ubuntu[private/dovecot-lmtp], delay=30047, delays=30047/0.03/0.02/0, dsn=4.4.2, status=deferred (lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:26:03 Ubuntu postfix/scache[3659]: statistics: start interval Jan 29 15:22:43
    Jan 29 15:26:03 Ubuntu postfix/scache[3659]: statistics: domain lookup hits=0 miss=1 success=0%
    Jan 29 15:29:44 Ubuntu postfix/smtpd[3765]: connect from nk11p03mm-asmtp001.mac.com[17.158.232.236]
    Jan 29 15:29:45 Ubuntu postfix/smtpd[3765]: BE8582C34DE: client=nk11p03mm-asmtp001.mac.com[17.158.232.236]
    Jan 29 15:29:45 Ubuntu postfix/cleanup[3776]: BE8582C34DE: message-id=<E8F48D16-3855-454E-BC72-0F3DE0899B03@me.com>
    Jan 29 15:29:45 Ubuntu postfix/qmgr[3157]: BE8582C34DE: from=<diogoandresaraiva@me.com>, size=1267, nrcpt=1 (queue active)
    Jan 29 15:29:45 Ubuntu dovecot: lmtp(3780): Fatal: Error reading configuration: Invalid settings: postmaster_address setting not given
    Jan 29 15:29:45 Ubuntu postfix/lmtp[3779]: BE8582C34DE: to=<cr7akg@cr7akg.com>, relay=Ubuntu[private/dovecot-lmtp], delay=0.23, delays=0.21/0.01/0.01/0, dsn=4.4.2, status=deferred (lost connection with Ubuntu[private/dovecot-lmtp] while receiving the initial server greeting)
    Jan 29 15:29:46 Ubuntu postfix/smtpd[3765]: disconnect from nk11p03mm-asmtp001.mac.com[17.158.232.236]

Results of : telnet cr7akg.com smtp

Trying 85.242.102.178...
Connected to cr7akg.com.
Escape character is '^]'.
220 Ubuntu ESMTP Postfix (Ubuntu)

Results of : telnet 192.168.1.104 smtp

Trying 192.168.1.104...
Connected to ubuntu.lan.
Escape character is '^]'.
220 Ubuntu ESMTP Postfix (Ubuntu)
  • What does your mail log show when it receives a message? – NickW Jan 29 '15 at 15:27
  • Do you have the appropriate firewall rule(s) set up for inbound SMTP to your server? – joeqwerty Jan 29 '15 at 15:29
  • @joeqwerty Are you asking if I have iptables setup? I have no iptables configured yet. – DiogoSaraiva Jan 29 '15 at 15:39
  • @NickW I updated my question please see above... thanks – DiogoSaraiva Jan 29 '15 at 15:41
  • iptables, network firewall, whatever. Does your firewall (host, network or otherwise) have the appropriate inbound rule(s) for inbound SMTP traffic to reach your server? Have you tried to telnet to your server from another machine on the LAN and from a machine on the internet? That's what I would suggest as a first step. – joeqwerty Jan 29 '15 at 15:44
2

Found this solution:

add this on /etc/dovecot/conf.d/20-lmtp.conf:

protocol lmtp {
postmaster_address = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf # required
mail_plugins = quota
}

probably this was:

protocol lmtp {
  # Space separated list of plugins to load (default is global mail_plugins).
  #mail_plugins = $mail_plugins
}

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.