1

Running a fresh installed Server 2008 R2 Standard (x64) with SP1 as a single HyperV host. This server has to replace an "old" 2008 R2 with a couple of HyperV VMs stored. After shutting all guest systems down I tried to copy all VHD files to the new server. Unfortunately after a couple of minutes the system freezes and I have to reset the machine. It's not possible to ping the machine until a reboot has proceeed. CPU, RAM, RAID, Drives are in good shape and have been stress tested for 48h. Each component of the server has been changed with new hardware.

The server has two Intel 82574L GBit network cards (onboard). I removed the virtual switch for HyperV and tried the copy process with both ethernet connections individually.

There are no warnings or even errors in the event log

  • Are you seeing disk IO contention when this copy is in progress? – EEAA Jan 29 '15 at 22:21
  • As an aside, that's not the way to transfer VM's from one host to another. From the Hyper-V Manager you'll want to export the VM's from the source host (to an interim storage location) and import them to the destination host (from the interim storage location). This method might also get you past this problem, so that you're not spending an inordinate amount of time on a problem server that's ultimately being decommissioned. – joeqwerty Jan 30 '15 at 0:47
  • Your disk controller might have a problem. Is it a on-board controller with a really small amount of cache ? Can you copy the VM to a USB disk to bring to the new server, to rule out if it's a nic problem or not. – yagmoth555 Jan 30 '15 at 1:19
  • It's an Adaptec 6405 RAID controller PCIe card. The default cache value has been set. Guess I'll try the migration with Veeam tomorrow. – Fabian Jan 30 '15 at 1:30
2

I suspect your issue is Windows Dynamic Cache. Basically, if your disk isn't fast enough to keep up, Windows caches the writes in memory and may use up to 100% of the memory for this.

You can, as of February 2014, manage the size of the cache yourself with this utility from Microsoft.

  • I'll give it a further try. Unfortunately a quick test while using the (demo) reg config file hasn't changed the system stability, yet. Furthermore the actual RAM usage wasn't that high. – Fabian Jan 29 '15 at 23:50
  • Still wasn't successful. This problem only occurs by copy a big amount of data. I can copy local a lot of GB without having any problems. Only if I try to copy e.g. 10 GB from another store, the server completely freezes. Even setting down the NIC's 1 GBit transfer rate to 100 MBit Full Duplex makes the same result. Unfortunately the event log doesn't show any issues. EDIT: Copied 300 GB locally and the system got stuck as well. The physical memory stays at ~16 of 32 GB ram usage. – Fabian Jan 30 '15 at 19:34
1

Try to use the robocopy tool (should be included on this Windows version) and see what you get this time.

Also prior beginning the copy either using GUI or robocopy open Resource Monitor by typing resmon and watch out I/O values as the other guy also suggested.

  • Got similar the same result with robocopy, the I/O got after about 20 minutes 100% and stood until the system got frozen. In the last second of resmon, the amount of 100 MB/s (not MBit) junped down to 0 KB/s. – Fabian Jan 29 '15 at 23:48
1

This problem has been resolved and is in this case related to the used Adaptec 6405 RAID controller. Disabling both, read and write cache, the system works perfect.

0

This is a Disk Management issue.
To stop a USB hard drive from freezing while copying data, you have to disable the default "Quick removal" and check the "Better performance" property in the Disk Management. This enables the "write caching" and in order to remove the drive without losing data, you must use the "Safely Remove Hardware" notification icon to disconnect the device safely.

  • It wasn't a disk management issue related with USB media. The raid controller has affected the performance and system health as well. – Fabian Mar 11 '16 at 22:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.