0

I want to be able to configure IE 11 group policy settings from my Win 7 client. I have IE 11 installed on this client. The client has been joined to a mixed Windows Server 2003/2008R2 domain. When I open the policy object from my Win 7 client and navigate to "User Configuration"->"Basic Settings"->"Control Panel" and right click on "Internet Settings" I can only see the option to add group policy settings for IE 5, 6, 7, and 8.

I tried downloading the ADMX templates for IE 11 (https://msdn.microsoft.com/en-us/library/bb530196.aspx) and installing them in %systemroot%\policyDefinitions on the client but nothing seems to change.

I read in a different thread (Internet Explorer 9 & 10 Group Policy Preferences missing) that I need Windows 8 or Server 2012 to accomplish what I want to do, but this seems strange to me. There are no Windows 8 or Server 2012 machines in my domain, and purchasing/acquiring one is an impossibility right now. Also, as an aside, all my servers have IE 8 installed, including the domain controllers, and upgrading to IE 11 is not possible right now (I don't know if this is an important point or not).

There has to be a way to accomplish what I am try to do. Can anybody lend a hand?

2

Put the ADMX in a central store where any computer can see it. Like in the SYSVOL directory in your DC.

Quoted from there

If you are running Windows 7 Professional, Enterprise or Ultimate you’ll find the ADMX files under %WINDIR%\PolicyDefinitions. It’s simply a matter of copying all files from the PolicyDefinitions folder on a Windows 7 client computer to the PolicyDefinitions folder on the domain controller contained in the SYSVOL folder: \FQDN\SYSVOL\FQDN\policies

  • I created PolicyDefinitions in \FQDN\SYSVOL\FQDN\policies and copied all the ADMX files from my client inside (I had the Windows 8.1 and Server 2012 R2 templates installed on my client). I reopened the target GPO for editing, but nothing seems to have changed. Maybe I've done something wrong? – wrieedx Jan 30 '15 at 6:19
  • I'm wondering if adding the ADMX files to \FQDN\SYSVOL\FQDN\policies\PolicyDefinitions makes any difference in the first place? The files were already installed locally and accessible/usable via the group policy editor. After shuffling them over to \FQDN\SYSVOL\FQDN\policies\PolicyDefinitions nothing really changed. Is there something else that needs to be done to make the add Internet Settings option for IE 10 appear? – wrieedx Feb 2 '15 at 23:51
  • It should do the job, in the custom adm. Can you select the good template and use it? – yagmoth555 Feb 2 '15 at 23:54
  • Maybe check to copy them to c:\windows\inf, if you got more than one dc please copy to both server c – yagmoth555 Feb 3 '15 at 0:10
  • By selecting the good template, do you mean manually adding inetres.adm to the GPO? Tried that and nothing changes. To make sure I wasn't using old templates I downloaded them again and reinstalled them (i.e. adm files to c:\windows\inf, admx files to C:\Windows\PolicyDefinitions and the central store in \FQDN\SYSVOL\FQDN\policies\PolicyDefinitions). Still no option to add IE 9/10 internet settings. Could it really be true that I need Win8 or Serv2012 to add these settings? It seems so ridiculous (especially since MS is forcing everyone to upgrade to IE11 by ending support for pre-IE11). – wrieedx Feb 4 '15 at 2:59

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.