0

I'm investigation a strange problem in our network. Two Windows XP machines access a file share on a Windows 2000 Server (which is a VMWare ESXi VM). Both are connected to that server via a D-Link DES-1024 R+ unmanaged 10/100MBit switch. One specific software on those machines reads a folder on that share everytime the application receives focus (i.e. Alt-Tab back to its window) with about 4600 files, 6MB total size. Here's the weird part: on one machine (let's call it A) this operation is very quick (<2s), on the other (B) it takes about 13 seconds. This makes the application very frustrating to use. Things I've tried to narrow the problem down so far:

  • Compared network settings on both machines. A has completely bog-standard settings, neither static IP nor DHCP makes any difference on B.
  • Updated network drivers on B (Intel Pro 1000). No effect.
  • Tried the second NIC on B (Intel 100 something). No effect.
  • Plugged B into a SMC switch to cut down cable length (about 20 meters to the closest port, then some 40 meters more to the server room upstairs, i.e. now 20 meters to SMC switch, then directly into the port). No effect.
  • Played around with disabling TCP offloading, disabling auto-negotiation and diagnostics in the Intel drivers. No effect.
  • Used a "LAN SpeedTest" application (which creates a file of e.g. 100MB, copies it to a file share and reads it back) to test raw performance. 50-70 MBit/s throughput can be easily achieved, so it seems to be a problem with accessing many small files vs. raw throughput. Pings are fine too (<1ms, no packet loss).
  • Copied the directory to a Windows 2008 R2 server (same VMWare server). No effect.
  • Copied the directory to a Synology DiskStation (Linux/Samba, physically separate device). No effect.
  • Hooked up B directly to a laptop, with the directory copied to a file share on that laptop. Works as expected now (very quick), so the machine seems to be ok hardware-wise.
  • Connected both laptop and machine via the SMC switch. Still works.
  • Connected B via the SMC switch to a different (known working) port in a different room, in case the one the machine normally uses is faulty. Switched back to original file share. Problem arises again.

I hope I did not forget anything, but all of the above leads me to the conclusion that somehow, the Intel Ethernet chips have a problem with the D-Link switch (since A works fine, but has an Atheros Ethernet chip, and the problem only arises if B is connected to whichever file share via the D-Link switch). Currently the machine is being used, but as soon as I get the chance I'll try to see if there's anything obvious in Wireshark. However, I have trouble understanding how a dumb switch could cause such problems. Is there any known incompatibility between Intel NICs and D-Link switches? Is the switch simply faulty? Thank you for any suggestions!

4

You are troubleshooting two operating systems who are both out support, and you're using consumer gear for your networking. It's impossible to tell you where the fault lies.

That being said - I've come across many D-Link switches when cleaning up networks and they all share the same fate (a trash can). Their products are simply put crap, and yes - I've experienced large network outages where a single 8 port D-Link switch managed to corrupt the ARP table of the 10 neighbouring switches.

  • I do kinda disagree with your statement that it's impossible to tell where the fault lies. Clearly, there's more than enough fault to say it lies everywhere. – HopelessN00b Jan 30 '15 at 8:02
  • Yes, the D-Link switch is crap, and as such is already slated to be replaced. But I have to live with the current equipment that I "inherited" for now. And yes, Windows XP is out of support, but these machines cannot be upgraded, and live on their own isolated network anyway. Just because they are out of support does not imply they magically have to develop mysterious network problems that no human can possibly identify or correct. I'll take this as a +1 on the "that D-Link switch simply sucks, and it's his fault, but no one knows why exactly" theory, then. – zakharov Jan 30 '15 at 8:32
  • @zakharov any kind of unmanaged network gear used in a professional manner (especially with products like ESXi) is asking for trouble, whether you inherited it or not. We've all been there at some point, but it's your responsibility as a sysadmin to get the equipment replaced before any more issues arise. – pauska Jan 30 '15 at 8:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.