3

Forgive me if I'm mixing up terminology, I'm a DBA and trying to see if I can un-do my error here.

Background: I was adding a 3rd DR site node to a Windows Server Failover Cluster to utilize AlwaysOn Availability Groups from SQL 2012. Already in the cluster are nodes 01 and 02, which are setup to be HA in our primary data center. Node 03 is not meant have clustered disks or votes in the WSFC, it is just a SQL requirement to be in the cluster for the AlwaysOn feature. All the storage is SAN managed through SnapDrive.

Problem: When I was adding node 03 to the cluster, I did not uncheck the "add all storage to cluster" checkbox so it added the non-system disks from node 03 to the cluster (data, log, tempdb disk, etc.). So now these disks are assigned to the "Cluster Shared Volume" and mounted on node 1 as C:\Cluster Shared Volume\MountPoint XXX.

enter image description here

If I remove them from the Cluster Shared Volume, they become Available Storage. These can then be removed from the cluster, but do not become mounted back on the original node. Once removed they appear in the node's Disk Management, but are offline and most options are grayed out as a result...so how can I get them online?

enter image description here

  • Have you right clicked them in Disk Management and selected the "Online" option? Is the "Online" option available? – joeqwerty Jan 31 '15 at 8:05
4

I did exactly what you did - I was adding a new node to an SQL 2014 AlwaysOn cluster and I forgot to uncheck the "Add Storage" button at the end of the wizard.

To get the storage back, and your cluster online:

  1. Remove all the disks "Cluster Shared Volumes" (Right-click, Remove from Cluster Shared Volumes)
  2. Remove all the disks from the cluster completent (Right-click, Remove, "Yes")
  3. Wait for a few minutes for each node in the cluster to remove its disks from being "in the cluster"
  4. On each node in the cluster, put each disk that is now offline, back online (this can be a slow and annoying process when doing this to remote servers on the far end of a slow WAN. Hope you don't have too many).
  5. Start the SQL Server service on all the affected nodes (don't forget the SQL Server Agent service as well)

For bonus points

  1. Pray this wasn't a production cluster
  2. Smack yourself repeatedly so you remember to always uncheck the button to add cluster storage in the cluster wizard
0

Right Click... Remove from Cluster Shared Volumes.

  • That was my initial solution, which reverts them to Available Storage. I can then remove them from the cluster completely after that, but they do not return to the node. So I'm left with unassociated disks still. – LowlyDBA Jan 30 '15 at 22:02
  • How is the server connected to the disk? Direct, iSCSI, Fiber Channel? – joeqwerty Jan 30 '15 at 22:03
  • connected via iSCSI – LowlyDBA Jan 30 '15 at 22:04
  • And you've checked/refreshed/rescanned in the Disk Management console? – joeqwerty Jan 30 '15 at 22:06
  • If it's still in the cluster, online, and assigned to Cluster Shared Volume, I can see them in DM. If I evict the node and remove them from the cluster, then they are offline in DM but visible with all right-click options grayed out. – LowlyDBA Jan 30 '15 at 22:12

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.