0

When trying to install PHP 5.6 from the iUS repo, I get this error:

    --> Processing Conflict: php56u-common-5.6.5-1.ius.el6.x86_64 conflicts php-common < 5.6
    --> Finished Dependency Resolution
    Error: php56u-cli conflicts with php-cli-5.3.3-22.el6.x86_64
    Error: Package: php56u-cli-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
    Error: Package: php56u-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
    Error: Package: php56u-cli-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libcrypto.so.10(OPENSSL_1.0.1)(64bit)
    Error: Package: php56u-common-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: php56u-common conflicts with php-common-5.3.3-22.el6.x86_64
    Error: Package: php56u-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
    Error: Package: php56u-cli-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libcrypto.so.10(OPENSSL_1.0.1_EC)(64bit)
    Error: Package: php56u-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
    Error: Package: php56u-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: Package: php56u-cli-5.6.5-1.ius.el6.x86_64 (ius)
               Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: php56u conflicts with php-5.3.3-22.el6.x86_64
     You could try using --skip-broken to work around the problem
     You could try running: rpm -Va --nofiles --nodigest

It seems to be due to the fact i have openssl 1.0.0 installed, and need a later version - but I do not know how to install that. Can anyone help?

marked as duplicate by Michael Hampton May 8 '15 at 18:50

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • You need to be on at least RHEL 6.5 and have an active RHEL subscription. – Michael Hampton May 8 '15 at 17:36
  • This is not a duplicate of the openssl question. IUS php56u packages are designed to conflict with their stock counterparts, so as to not be automatically updated by accident. You need to erase the stock php packages and install the IUS php56u packages in a single transaction, such as with yum shell or the yum replace plugin. Please see ius.io/Usage for more details and examples. – carlwgeorge Feb 23 '16 at 20:04
1

You appear to have already PHP installed (version 5.3.3).
Those packages conflict, you cannot have both the IUS and base version installed.
If you want to use IUS, you should replace the old version as described here:
https://iuscommunity.org/pages/IUSClientUsageGuide.html#upgrading-stock-rhel-packages-to-ius-packages

Probably something like

yum replace php --replace-with php56u  

should work.

  • that was probably the first thing i tried, and it resulted in the error listed above. – Barry Chapman Feb 1 '15 at 20:25
  • @barry-chapman That isn't likely. The replace plugin would have automatically handled erasing php in the same transaction as installing php56u. Next time include the actual command you ran with the error output. – carlwgeorge Feb 23 '16 at 20:18
0

I know it's a bit late but this worth to answer(maybe save a little time for someone else)

you can use this command to installing on RHEL or CentOS

sudo yum --enablerepo remi,remi-php56 install php56u php56u-common php56u-mysqlnd php56u-cli php56u-pecl-mongo php56u-gd php56u-mbstring php56u-mcrypt php56u-xml -y

in fact you just needed to replace php with php56u, this way you don't change anything in system

  • php56u is from IUS, not remirepo. In general, mixing third party repositories is a bad idea. Remirepo in particular obsoletes other third party repo packages, so you have to use remi packages when remirepo is enabled. – carlwgeorge Feb 23 '16 at 20:14

Not the answer you're looking for? Browse other questions tagged or ask your own question.