6

I'm having a problem with a server that I just installed kernel 2.6.18-371.el5 on. It's an old kernel for Red Hat 5, I know, but due to certain "restrictions" I am forced into using that for the time being. It should also be noted that this distro that I installed was a kickstart with various security software pre-installed.

Regardless, I have a local repo on an external USB HDD and for the life of me I can't seem to get the system to load the drivers for the drive. Due to other network restrictions I'm not able to post log messages from it either, or connect the server to a public line. So I'll do my best to hand jam important info. I'm fairly Linux competent, but new to the loading of drivers into the kernel and such. So if some of my explanation seems weird, I'm sorry.

What I've done so far:

-"ls /dev" shows: "usbdev1.5_ep00, ...01, ...81" ...when I plug the drive in. But no "sd*" for the drive at all.

-"blkid" only shows me my OS partitions and the CDROM mount. No USB mounts at all

-"fdisk -l" shows my three physical drives "sda, sdb and sdc", which correspond to my three internal SAS drives. They are working fine.

-"dmesg" only displays: "usb 1-4.1:1.0: new high speed USB device using ehci_hcd and address 5" "usb 1-4.1:1.0: configuration #1 chosen from 1 choice" ...and that's it. No discovery of any more device info.

-"lsmod" shows "ehci_hcd", "uhci_hcd" and "ohci_hcd" all loaded and nothing else.

-"lsusb" shows Bus 001 Device 004 and Device 003 : Cypress Semiconductor Corp USB 2 TetraHub, Bus 002 Dev 004 Raritan Computer, and then 4 other blank bus devices...7 in total. (The Raritan is the Ethernet Attached KVM using the USB Keyboard and mouse)

-"yum list libusb" shows that libusb.x86_64 is installed

So far I've searched for a few hours for solutions on this issue. I've tried modprobing usb_storage and ehci_hcd. I've tried rebooting with the drive plugged in. I've looked in the BIOS and it appears that the drive is being seen in there. I've reinstalled the kernel rpm in hopes that something would be corrected.

Does anyone have any ideas on how I can get the USB working for block devices? I'd be very grateful for any help to do so.

It should also be noted that the kickstart grub config came with a nousb line that I deleted in order to use a USB keyboard and mouse. Both work without issue now and are discovered in the above commands.

  • 2
    If usbutils is installed then lsusb could show something useful? – shearn89 Feb 2 '15 at 13:52
  • Thank you, I forgot to add that and edited the original question to include those results. – cclater Feb 2 '15 at 14:02
  • 1
    You should have at least the usb_storage module. – wurtel Feb 2 '15 at 15:20
  • I thought so too, so I do an "lsmod" and there is no "usb_storage" loaded that I can find. So I "modprobe usb_storage", it returns no errors, and then "lsmod" again and still nothing. Is there somewhere it could be blocked? I can't find it in any modprobe conf blacklist. – cclater Feb 2 '15 at 17:37
  • Could you please provide the full output of lsubs -v? – Thomas Berger Mar 3 '15 at 12:32
0

Try this:

insmod /lib/modules/$(uname -r)/kernel/drivers/usb/storage/usb-storage.ko

then remove and re-plug the drive and check dmesg.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.