I have set up DNS on my Linux Centos server and when I test on this site I get the following errors:

WARNING: One or more of your nameservers did not return any of your NS records.

ERROR: One or more of your nameservers did not respond:

The ones that did not respond are:

49.50.77.196 49.50.77.200

Researching across the web/Stack Exchange, I understand it appears to be my DNS A records that aren't correctly set up but for the life of me and 2 days trial/error I cannot find what is wrong:

dig indulgense.com

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6_6.1 <<>> indulgense.com
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 39107
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;indulgense.com.                        IN      A

;; Query time: 5005 msec
;; SERVER: 8.8.8.8#53(8.8.8.8)
;; WHEN: Mon Feb  2 20:28:42 2015
;; MSG SIZE  rcvd: 32

dig @49.50.77.196 indulgense.com. soa

; <<>> DiG 9.8.2rc1-RedHat-9.8.2-0.30.rc1.el6_6.1 <<>> @49.50.77.196 indulgense.com. soa
; (1 server found)
;; global options: +cmd
;; connection timed out; no servers could be reached

My /var/named/indulgense.com.zone zone file is:

$TTL    7200
@       IN      SOA     indulgense.com. contact.indulgense.com. (
                        2015020211      ; Serial        yyyymmddss (ss: sequence serial)
                        7200            ; Refresh       3h
                        3600            ; Retry         1h
                        240800          ; Expire
                        7200            ; Minimum       3h
)

@       IN NS           ns1.indulgense.com.
@       IN NS           ns2.indulgense.com.
ns1     IN A            49.50.77.196
ns2     IN A            49.50.77.200
ftp     IN CNAME        indulgense.com.
www     IN CNAME        indulgense.com.
*       IN CNAME        indulgense.com.
@       IN MX 10        indulgense.com.

indulgense.com. IN A 49.50.77.196
indulgense.com. IN TXT "v=spf1 ip4: 49.50.77.196/29 -all"

bindera.indulgense.com. IN A 49.50.77.200
bindera.indulgense.com. IN TXT "v=spf1 ip4: 49.50.77.200/29 -all"

This is my /etc/named.conf file:

//
// named.conf
//
// Provided by Red Hat bind package to configure the ISC BIND named(8) DNS
// server as a caching only nameserver (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//

options {
        listen-on port 53 { 127.0.0.1; };
        listen-on-v6 port 53 { ::1; };
        directory       "/var/named";
        dump-file       "/var/named/data/cache_dump.db";
        statistics-file "/var/named/data/named_stats.txt";
        memstatistics-file "/var/named/data/named_mem_stats.txt";
        allow-query     { any; };
        recursion no;

        dnssec-enable yes;
        dnssec-validation yes;
        dnssec-lookaside auto;

        /* Path to ISC DLV key */
        bindkeys-file "/etc/named.iscdlv.key";

        managed-keys-directory "/var/named/dynamic";
};

logging {
        channel default_debug {
                file "data/named.run";
                severity dynamic;
        };
};

zone "." IN {
        type hint;
        file "named.ca";
};

include "/etc/named.rfc1912.zones";
include "/etc/named.root.key";


zone "indulgense.com" IN {
                type master;
                file "/var/named/indulgense.com.zone";
                allow-update { none; };
        };

Any help would be appreciated along with any other info needed...

  • Firstly, you may be a beginner, but we expect you to spend the time required to make your post readable. Secondly, thank you for at least not redacting the domain name; that does help. Thirdly, at the moment the problem seems to be that both your DNS servers are unresponsive; UDP to port 53 is rejected, as are TCP connection attempts. Is it possible that you have some kind of firewall in front of those DNS servers (49.50.77.196, 49.50.77.200)? – MadHatter Feb 2 '15 at 15:22
  • Thanks for the advice - I had spent a lot of time trying to ensure the question was readable and had all the info you might need... not sure what more would help - any advice gratefully accepted. – setenson mile Feb 2 '15 at 15:29
  • Solved the problem - commented those two lines out - thank you :) – setenson mile Feb 2 '15 at 15:29
up vote 2 down vote accepted

In your named.conf file, you listen only to the localhost adapter, not to any external addresses. That will definitely be a problem since the rest of the world is talking to you through your external addresses. Fix that, then keep debugging (if needed).

  • 1
    ie. substitute 127.0.0.1 with a public interface address – Mathias R. Jessen Feb 2 '15 at 15:23
  • This has solved it - fantastic - thank you so so much! – setenson mile Feb 2 '15 at 15:26

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.