I've inherited a fun munin set up, so this may end up being something weird.

I've got a Windows Server 2008 server running "Munin Node For Windows". With the munin-server running on a separate linux box. The issue is with [Disk Plugin].

We've just added a new partition on the SAN (the 11th drive), but it's not appearing on the munin graphs that are being generated.

Running telnet and "fetch df" from the linux box to the window shows that the node is outputting all the required values: "_dev_0_.value" all the way to "_dev_10_.value".

But on the graph, it doesn't display anything for this new partition (however, all the others are being kept up to date).

I've searched through the settings for any kind of cap on the number of plots per graph, or mapping the drive names -> letters and haven't seen anything.

Munin version on linux is: 2.0.25

I imagine it might be something obvious, but I've failed at searching for a solution. Not sure what information is entirely relevant; so sorry if this is a bit sparse.

Your assistance would be greatly appreciated! Thanks!

Update 1: The following was obtained from munin-graph -debug:

2015/02/04 11:56:03 [DEBUG] Doing work synchronously 2015/02/04 11:56:03 [DEBUG] root/XXXX/XXXXX/df is in (root/XXXX/XXXXX/df) 2015/02/04 11:56:03 [DEBUG] root/XXXX/XXXXX/df is in () 2015/02/04 11:56:03 [DEBUG] Node name: df 2015/02/04 11:56:03 [DEBUG] Expanding specials for df: >"_dev_0_","_dev_1_","_dev_2_","_dev_3_","_dev_4_","_dev_5_","_dev_6_","_dev_7_","_dev_8_","_dev_9_". 2015/02/04 11:56:03 [DEBUG] expand_specials(): not processed, proceeding for $VAR1 = { '#%#name' => 'df', '_dev_0_' => { '#%#name' => '_dev_0_', 'critical' => '93', 'graph_data_size' => 'normal', 'label' => 'C:', 'update_rate' => '300', 'warning' => '88' },

(etc...all the way up to _dev_9)

It then says things like:

2015/02/04 11:56:03 [DEBUG] service XXXXXX :: XXXXXX :: df has 10 elements

Could the graph_order be being set somewhere on the munin-server side? Seems a little odd?

Update 2: So, the rrd files look fine, but after a bit of digging it looks like the datafile doesn't have a label set for it, and the graph_order doesn't include the _dev_10_.

What sets the the datafile (/var/lib/munin/datafile)?? That seems to be the thing that is used by munin-graph to actually draw the stuff?

I tried adding the missing values, but they got automatically removed??


On Ubuntu 20.04 server problem was related to systemd. I solved that by changing (as a root user) /usr/sbin/munin-run file from:

my $ignore_systemd_properties = 0;


my $ignore_systemd_properties = 1;

Or, as I found out, more proper solution is: to change /lib/systemd/system/munin-node.service file from:




And then restart services:

systemctl restart munin-node
systemctl daemon-reload

For any change done on a munin node, you have to restart the munin node service on that node (machine).

On that windows machine, go to services, find the one installed by munin and restart the service.

  • Thanks Dan. I've tried that, but it hasn't fixed the problem. As far as I can tell the munin-node on the server is outputting what it should be. But it's not appearing on the graphs. – THJSmith Feb 2 '15 at 18:11
  • Then lets take it step by step. On the server, somewhere in /var/lib/munin depending on how you configured nodes, there should be rrd files named clientname-df-_dev_N-g.rrd. Check if you have the rrd file for _dev_10, besides those for 0..9 – Dan Feb 2 '15 at 19:30
  • Great. Thank you. Yes, there's an rrd file for each of the dev files. They're all 50k. – THJSmith Feb 3 '15 at 10:37
  • To debug munin server you can run something like below. My system is ubuntu 10.04, on others paths may differ. To debug graph generation su -s /bin/bash munin -c "/usr/share/munin/munin-graph --debug --nofork" and to debug data gathering su -s /bin/bash munin -c "/usr/share/munin/munin-update --debug --nofork". Also check log files in /var/log/munin for errors. – Dan Feb 3 '15 at 17:14
  • Updated main post with details obtained. Thanks Dan. :) – THJSmith Feb 4 '15 at 12:16

I seem to have found a way to solve this

using your favorite editor (mine is vi but for simplicity we'll use nano)

sudo nano /etc/munin/plugin-conf.d/df

paste this

  env.exclude none unknown iso9660 squashfs udf romfs ramfs vfat debugfs nilfs2 rootfs
  env.warning 92
  env.critical 98
  env.include_re ^/home

  env.exclude none unknown iso9660 squashfs udf romfs ramfs vfat debugfs nilfs2 rootfs
  env.warning 92
  env.critical 98
  env.include_re ^/home

you can check for the corresponding line to show

sudo munin-run df

in my case it returns device

_dev_vdb1.value 51.7198789876806

then restart munin-node

sudo service munin-node restart
  • please note that on a debian buster vbox, I do get to see the home partition via sudo munin-run df but it still doesn't show up in the graph – Antony Gibbs Apr 20 '20 at 14:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.