1

I have a Cinder storage and controller node running on the same CentOS 7 box as Nova compute. Everything worked fine, until I rebooted. Now my instances can't mount volumes and I get the errors below.

dmesg:

[  923.546115] scsi5 : iSCSI Initiator over TCP/IP
[  923.560908] iSCSI Initiator Node: iqn.1994-05.com.redhat:c87d91366225 is not authorized to access iSCSI target portal group: 1.
[  923.561124] iSCSI Login negotiation failed.
[  923.561207]  connection3:0: detected conn error (1020)

nova-compute.log:

2015-01-28 14:51:42.460 1962 TRACE oslo.messaging.rpc.dispatcher ProcessExecutionError: Unexpected error while running command.
2015-01-28 14:51:42.460 1962 TRACE oslo.messaging.rpc.dispatcher Command: sudo nova-rootwrap /etc/nova/rootwrap.conf iscsiadm -m node -T iqn.2010-10.org.openstack:volume-ce40f03f-4d2e-4af7-9157-753f33bd0fd0 -p 192.168.11.212:3260 --rescan
2015-01-28 14:51:42.460 1962 TRACE oslo.messaging.rpc.dispatcher Exit code: 21
2015-01-28 14:51:42.460 1962 TRACE oslo.messaging.rpc.dispatcher Stdout: u''
2015-01-28 14:51:42.460 1962 TRACE oslo.messaging.rpc.dispatcher Stderr: u'iscsiadm: No session found.\n'

Output of service iscsid status -l:

Jan 28 14:41:47 alpsose01.ovationpayroll.com iscsid[4391]: conn 0 login rejected: initiator failed authorization with target
Jan 28 14:41:47 alpsose01.ovationpayroll.com iscsid[4391]: Connection2:0 to [target: iqn.2010-10.org.openstack:volume-088b52de-9422-44f3-ae3c-e48b62863081, portal: 192.168.1.212,3260] through [iface: default] is shutdown.
Jan 28 14:51:42 alpsose01.ovationpayroll.com iscsid[4391]: conn 0 login rejected: initiator failed authorization with target
Jan 28 14:51:42 alpsose01.ovationpayroll.com iscsid[4391]: Connection3:0 to [target: iqn.2010-10.org.openstack:volume-ce40f03f-4d2e-4af7-9157-753f33bd0fd0, portal: 192.168.1.212,3260] through [iface: default] is shutdown.

target.service is started with no errors and my iSCSI configuration is not using ACLs. cinder-scheduler and cinder-volume services are both in the down state, even though they're enabled.

I've searched and found others with this problem, but no solutions. Any help is appreciated!

1

Added the following to /etc/cinder/cinder.conf on the storage node:

[DEFAULT]
enabled_backends=lvm57
[lvm57]
iscsi_helper=lioadm
volume_group=cinder-volumes
volume_driver=cinder.volume.drivers.lvm.LVMISCSIDriver
iscsi_ip_address=192.168.186.168
volume_backend_name=LVM_iSCSI

https://ask.openstack.org/en/question/55529/couldnt-start-any-instances-after-cinder-rebooted/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy